[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] RFX2200 driver broken in latest git code

From: Ed Criscuolo
Subject: Re: [Discuss-gnuradio] RFX2200 driver broken in latest git code
Date: Fri, 10 Dec 2010 14:46:33 -0500
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20101013 Thunderbird/3.1.5

On 12/10/10 12:24 PM, Jason Abele wrote:
On Thu, Dec 9, 2010 at 5:15 AM, Ed Criscuolo
<address@hidden>  wrote:
Since the RFX2200 does not seem to be supported by GR 3.3.0, I switched
over to the latest git source and tried it.  It seems to be broken
with respect to the RFX2200.  Probing the USRP now detects the card's
name correctly (Flex 2200 Rx MIMO B), but still complains that it
has "... invalid EEPROM contents ..."  and will be treated as a
"Basic Rx" board.

Jason,  as I mentioned in another post, the list server is behaving
strangely, not delivering some posts until almost a day later.  I
sent the above post BEFORE I ever got any of your e-mails!

Could you clarify this a bit ... is usrp_probe telling you "invalid
EEPROM contents", is that usrp_fft.py or usrp_siggen.py or some other
app using the usrp?

Both usrp_probe and gnuradio-companion are producing this message.

Is this on gnuradio.org "master"?  .....


................Did you apply the patch I sent?

I tried applying the first patch you sent to a clone of the GnuRadio
master, but the patch application failed, so I couldn't test it.

You can get working usrp1 GNURadio 3.3 or master support for RFX2200
from my github repos while we get it merged into gnuradio.org
maint/master/next branches.

git remote add jabele-github git://github.com/jasonabele/gnuradio.git

Then, for GNUradio 3.3 support:
git checkout jabele-github/rfx2200_maint

For GNUradio "master":
git checkout jabele-github/rfx2200

If you build one of those and confirm it works on the mailing list, it
will speed up the merge into gnuradio.org

Last night (Thurs) did a clone from
git://github.com/jasonabele/gnuradio.git ,
and successfully built and installed it on Ubuntu 10.04LTS.
Both usrp_probe and gnuradio-companion are now able to talk to the
RFX2200 on a USRP1 without getting any error. It seems to work.

Thanks again for all your help.

Any idea when a 3.3.1 maintenance release will be officially out?

@(^.^)@ Ed

reply via email to

[Prev in Thread] Current Thread [Next in Thread]