[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gnuradio volk compilation err or: error: ‘_mm_pop

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] gnuradio volk compilation err or: error: ‘_mm_popcnt_u64’ was not declared in this sco pe
Date: Thu, 16 Dec 2010 21:08:56 -0500

On Thu, Dec 16, 2010 at 6:28 PM, Ruben Merz
<address@hidden> wrote:
> Hi all,
> I started a fresh build from the branch next of gnuradio (revision
> 1047775464c1bb8a86e727487551e2b14abd476e).
> Compilation currently fails within volk:
> In file included from qa_64u_popcnt_aligned16.cc:4:
> ../include/volk/volk_64u_popcnt_aligned16.h: In function ‘void
> volk_64u_popcnt_aligned16_sse4_2(uint64_t*, uint64_t)’:
> ../include/volk/volk_64u_popcnt_aligned16.h:45: error: ‘_mm_popcnt_u64’ was
> not declared in this scope
> I've tried including directly smmintrin.h in volk_64u_popcnt_aligned16.h but
> that did not work either.
> My machine is using Ubuntu 10.04 LTS (32 bits version), gcc 4.4.3, autoconf
> 2.65.
> CPU is an Intel quadcore i7 930.
> Ruben

I have the same processor at home running on 10.04 64-bit. We've had
issues with running 32-bit OSes on 64-bit processors. I thought these
were worked out, but there must be another issue.

Try configuring volk with "configure --with-lv_arch="generic 64 mmx
sse sse2 sse3 ssse3 sse4_a sse4_1 sse4_2" or whatever simd flavors you
want to support. Let me know if that works.

I also need to put the --with-lv_arch as a configuration option in the
gnu radio configure.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]