[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gnuradio make error

From: Don Ward
Subject: Re: [Discuss-gnuradio] gnuradio make error
Date: Fri, 17 Dec 2010 18:51:53 -0500

alirazib wrote:

I have installed cygwin with all the required packages, and then installed
boost, portaudio, SDCC and FFTW. WxPython could not be installed (WxWidgets was okay, but then error occurred during 'make'). Anyway, I thought WxPython is not absolutely vital for the initial experiments, so I left it like that. Then during the installation of gnuradio, I could configure (using command:
./configure --disable-all-components --enable-omnithread --enable-gruel
--enable-gnuradio-core --enable-gr-audio-oss), but I am getting error during

make  all-recursive
make[1]: Entering directory `/usr/src/gnuradio-3.3.0'
Making all in config
make[2]: Entering directory `/usr/src/gnuradio-3.3.0/config'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/src/gnuradio-3.3.0/config'
Making all in gruel
make[2]: Entering directory `/usr/src/gnuradio-3.3.0/gruel'
Making all in src
make[3]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src'
Making all in lib
make[4]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib'
Making all in pmt
make[5]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
make  all-am
make[6]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
/bin/sh ../../../../libtool --tag=CXX   --mode=link g++ -g -O2  -Wall
ed-virtual  -no-undefined -avoid version  -o libpmt-qa.la  qa_pmt.lo
s.lo qa_pmt_unv.lo libpmt.la -lcppunit -ldl   -lstdc++

/usr/bin/grep: /usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la: No such file
or directory

It looks like someone is trying the find a library file associated with gcc 4.3.2. I have never seen 4.3.2 on Cygwin; I know that 4.3.4 has problems with GNU Radio but 3.4.4 worked the last time I tried it.

What version of g++ are you using (i.e., what does "g++ --version" say)? What do you see when you say "ls /usr/lib/gcc/i686-pc-cygwin"?


Can anyone suggest me what to do? I need to install USRP2 drivers after this
step. And is WxPython really needed for simple experiments?

WxPython is really useful for visualizing what is happening, but is not absolutely required.

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]