[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gnuradio make error

From: alirazib
Subject: Re: [Discuss-gnuradio] gnuradio make error
Date: Sun, 19 Dec 2010 17:06:46 -0800 (PST)

Hi Don: 

Thanks for your feedback. I have followed your suggestions to install a new
cygwin with gcc 3.4.4 for gnuradio. Still WxPython could not be built. Step
9 ($ python setup.py build_ext --inplace WXPORT=msw COMPILER=cygwin
=0 BUILD_GIZMOS=0 UNICODE=0) gives the following error:

WARNING: WXWIN not set in environment. Assuming '..'
Found wx-config: /usr/local/bin/wx-config
    Using flags:  --toolkit=msw --unicode=no --version=2.8
Preparing CORE...
Preparing STC...
running build_ext
building '_html' extension
gcc -mcygwin -mdll -O -Wall -DSWIG_TYPE_TABLE=_wxPython_table
SINGDLL -D__WXMSW__ -Iinclude -Isrc
-2.8 -I/usr/local/include/wx-2.8 -I/usr/include/python2.6 -c
pp -o build/temp.cygwin-1.7.7-i686-2.6/src/msw/html_wrap.o -O3
src/msw/html_wrap.cpp: In function `PyObject*
ject*, PyObject*)':
src/msw/html_wrap.cpp:4501: warning: `GetWindow' is deprecated (declared at
src/msw/html_wrap.cpp: In member function `virtual wxHtmlOpeningStatus
indow::OnOpeningURL(wxHtmlURLType, const wxString&, wxString*) const':
src/msw/html_wrap.cpp:3115: warning: 'rval' might be used uninitialized in
writing build/temp.cygwin-1.7.7-i686-2.6/src/msw/_html.def
g++ -mcygwin -shared -s build/temp.cygwin-1.7.7-i686-2.6/src/msw/html_wrap.o
ld/temp.cygwin-1.7.7-i686-2.6/src/msw/_html.def -L/usr/local/lib
on2.6/config -lwx_msw_richtext-2.8 -lwx_msw_aui-2.8 -lwx_msw_xrc-2.8
-2.8 -lwx_msw_html-2.8 -lwx_msw_adv-2.8 -lwx_msw_core-2.8 -lwx_base_xml-2.8
_base_net-2.8 -lwx_base-2.8 -lpython2.6 -o
building '_media' extension
gcc -mcygwin -mdll -O -Wall -DSWIG_TYPE_TABLE=_wxPython_table
SINGDLL -D__WXMSW__ -Iinclude -Isrc
-2.8 -I/usr/local/include/wx-2.8 -I/usr/include/python2.6 -c
cpp -o build/temp.cygwin-1.7.7-i686-2.6/src/msw/media_wrap.o -O3
writing build/temp.cygwin-1.7.7-i686-2.6/src/msw/_media.def
g++ -mcygwin -shared -s
build/temp.cygwin-1.7.7-i686-2.6/src/msw/media_wrap.o bu
ild/temp.cygwin-1.7.7-i686-2.6/src/msw/_media.def -L/usr/local/lib
thon2.6/config -lwx_msw_richtext-2.8 -lwx_msw_aui-2.8 -lwx_msw_xrc-2.8
qa-2.8 -lwx_msw_html-2.8 -lwx_msw_adv-2.8 -lwx_msw_core-2.8
-lwx_base_xml-2.8 -l
wx_base_net-2.8 -lwx_base-2.8 -lpython2.6 -o
      3 [main] python 4516 C:\cygwin\bin\python.exe: *** fatal error -
unable to
 remap \\?\C:\cygwin\lib\python2.6\lib-dynload\time.dll to same address as
t: 0x260000 != 0x340000
Stack trace:
Frame     Function  Args
002296E8  6102749B  (002296E8, 00000000, 00000000, 00000000)
002299D8  6102749B  (61177B80, 00008000, 00000000, 61179977)
0022AA08  61004AFB  (611A136C, 6123F284, 00260000, 00340000)
End of stack trace
      3 [main] python 268 fork: child 4516 - died waiting for dll loading,
error: Resource temporarily unavailable

Anyway, then I tried to make gnuradio, but with the same error:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../../../..
-I/usr/local/include -I
clude -g -O2 -Wall -Woverloaded-virtual -MT qa_pmt_unv.lo -MD -MP -MF
mt_unv.Tpo -c qa_pmt_unv.cc  -DDLL_EXPORT -DPIC -o .libs/qa_pmt_unv.o
mv -f .deps/qa_pmt_unv.Tpo .deps/qa_pmt_unv.Plo
/bin/sh ../../../../libtool --tag=CXX   --mode=link g++ -g -O2  -Wall
ed-virtual  -no-undefined -avoid version  -o libpmt-qa.la  qa_pmt.lo
s.lo qa_pmt_unv.lo libpmt.la -lcppunit -ldl   -lstdc++
/usr/bin/grep: /usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la: No such file
or d
/usr/bin/sed: can't read /usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la: No
 file or directory
libtool: link: `/usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la' is not a
valid l
ibtool archive
make[6]: *** [libpmt-qa.la] Error 1
make[6]: Leaving directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/usr/src/gnuradio-3.3.0/gruel/src/lib'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/gnuradio-3.3.0/gruel/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/gnuradio-3.3.0/gruel'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gnuradio-3.3.0'
make: *** [all] Error 2

The problem I see is, it is looking for
/usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la; but there is NO /usr/lib on
my cygwin installation. The lib directory is installed directly under
cygwin, and it contains only the version 3.4.4 of gcc. So how can I have
this /lib move to /usr/lib during cygwin installation? 


Don Ward wrote:
> alirazib wrote:
>> I have installed cygwin with all the required packages, and then
>> installed
>> boost, portaudio, SDCC and FFTW. WxPython could not be installed 
>> (WxWidgets
>> was okay, but then error occurred during 'make'). Anyway, I thought 
>> WxPython
>> is not absolutely vital for the initial experiments, so I left it like 
>> that.
>> Then during the installation of gnuradio, I could configure (using 
>> command:
>> ./configure --disable-all-components --enable-omnithread --enable-gruel
>> --enable-gnuradio-core --enable-gr-audio-oss), but I am getting error 
>> during
>> 'make':
>> make  all-recursive
>> make[1]: Entering directory `/usr/src/gnuradio-3.3.0'
>> Making all in config
>> make[2]: Entering directory `/usr/src/gnuradio-3.3.0/config'
>> make[2]: Nothing to be done for `all'.
>> make[2]: Leaving directory `/usr/src/gnuradio-3.3.0/config'
>> Making all in gruel
>> make[2]: Entering directory `/usr/src/gnuradio-3.3.0/gruel'
>> Making all in src
>> make[3]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src'
>> Making all in lib
>> make[4]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib'
>> Making all in pmt
>> make[5]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
>> make  all-am
>> make[6]: Entering directory `/usr/src/gnuradio-3.3.0/gruel/src/lib/pmt'
>> /bin/sh ../../../../libtool --tag=CXX   --mode=link g++ -g -O2  -Wall
>> -Woverload
>> ed-virtual  -no-undefined -avoid version  -o libpmt-qa.la  qa_pmt.lo
>> qa_pmt_prim
>> s.lo qa_pmt_unv.lo libpmt.la -lcppunit -ldl   -lstdc++
>> -lwinmm
>> /usr/bin/grep: /usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la: No such 
>> file
>> or d> irectory
> This is caused by using Cygwin cppunit 1.12.1-1 (apparently compiled with 
> gcc 4.3.2); use cppunit 1.12.0-1 instead (works with gcc 3.4.4).
>> Can anyone suggest me what to do? I need to install USRP2 drivers after 
>> this
>> step. And is WxPython really needed for simple experiments?
> I have updated the Cygwin installation instructions for wxPython and GNU 
> Radio on the wiki.  The important changes are: (1) don't use cppunit
> 1.12.1; 
> (2) use Python 2.6 (instead of 2.5); (3) for wxPython you don't 
> need the patch that was used in 2.8.10, but you do need to patch Python
> 2.6 
> distutils.
> I have tested the new instructions (as far as the minium installation of 
> gnuradio-3.3.0) and they work for me.  If they don't work for you, send 
> details of what doesn't work and we will see if we can fix it.
> -- Don W.
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

View this message in context: 
Sent from the GnuRadio mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]