[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] cannot detect USRP2 on ubuntu 9.10 whatsoever...v

From: yyl
Subject: Re: [Discuss-gnuradio] cannot detect USRP2 on ubuntu 9.10 whatsoever...various solutions adopted...
Date: Tue, 04 Jan 2011 18:11:14 +0800
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101208 Thunderbird/3.1.7

Thanks for reply.

It seems to be the problem of the promiscuous mode(broadcast&multicast) of the ethernet card...I use wireshark to detect the packet transmission between pc and usrp2 when it plugs in. Surprisingly find_usrps works and both sent and received packets are detected. It looks that the wireshark opens the broadcast and multicast that lets usrp2 run correctly..although I still have not found the reason.

But it at least works:)

On 01/04/2011 05:30 PM, Andrew Rich wrote:
  Arp ?

This should return the Mac address and any ip address heard

Does a usrp. Ping ?

Sent from my iPhone
Andrew Rich

On 04/01/2011, at 18:53, yyl<address@hidden>  wrote:

Happy new year!
Just to notify, my ethernet works fine -- I could use wired internet to connect 
to the Internet.

On 12/31/2010 01:34 AM, Nick Foster wrote:
Verify that the ethernet card (and cable) work with another device such
as a network switch. The USRP2 should work with any gigabit Ethernet
card supported in Linux.


On Thu, 2010-12-30 at 20:23 +0800, yyl wrote:
On 12/22/2010 02:10 AM, Nick Foster wrote:
If the ethtool output you provided is with the USRP2 plugged in and
turned on, then your ethernet card isn't detecting a link. If another
computer works fine with that same USRP2, I suspect the ethernet cable
or your ethernet card as the culprit. You might also try:

sudo ifconfig eth0 up

and see if that affects the result of your ethtool output.


On Tue, 2010-12-21 at 11:34 +0800, yulong yang wrote:
Hi all,

I am new to gnuradio and stuck with the usrp2 connection for several
days... I looked up tens of search results but no solution yet.
Therefore I post my problem and hope someone could give me a hand:

I am running gnu radio 3.2.2 on ubuntu9.10, and I think gnuradio works
fine because dial_tone.py and grc all could be launched correctly.
However, when I plug in USRP2, problems happen:

if I typed in "sudo find_usrps" it says: No USRP2 found.

if I typed "sudo find_usrps -e eth0" it also says No USRP2 found.
(eth0 is what I get when typing in ifconfig)

if I typed in "sudo usrp2_fft.py" t says:

Traceback (most recent call last):
    File "/usr/local/bin/usrp2_fft.py", line 273, in<module>
      main ()
    File "/usr/local/bin/usrp2_fft.py", line 269, in main
      app = stdgui2.stdapp(app_top_block, "USRP2 FFT", nstatus=1)
line 36, in __init__
      wx.App.__init__ (self, redirect=False)
line 7978, in __init__
line 7552, in _BootstrapApp
      return _core_.PyApp__BootstrapApp(*args, **kwargs)
line 39, in OnInit
      frame = stdframe (self.top_block_maker, self.title, self._nstatus)
line 60, in __init__
      self.panel = stdpanel (self, self, top_block_maker)
line 81, in __init__
      self.top_block = top_block_maker (frame, self, vbox, sys.argv)
    File "/usr/local/bin/usrp2_fft.py", line 70, in __init__
      self.u = usrp2.source_32fc(options.interface, options.mac_addr)
    File "/usr/local/lib/python2.6/dist-packages/gnuradio/usrp2.py",
line 644, in source_32fc
      return _usrp2.source_32fc(*args, **kwargs)
RuntimeError: No USRPs found on interface eth0

What exactly the problem is?
TO note:
1. python is fine. I ran following process and it did not say error:
    Python 2.6.4 (r264:75706, Dec  7 2009, 18:45:15)
    [GCC 4.4.1] on linux2
    Type "help", "copyright", "credits" or "license" for more
    >>>    from gnuradio import gr
    >>>    from gnuradio import usrp
    >>>    from gnuradio import audio
    >>>    from gnuradio import usrp2
    >>>    exit()

2. could it be the firmware in usrp2? I saw some threads discussing
firmware in SD card. But it seems to run process like usrp2_fft.py
dose not need any firmware.

3. my usrp2 runs fine. I checked it with another computer which could
launch usrp_fft.py correctly. Also, when I power on usrp2, all 6
lights flah and then D and F remain on.

4. my ethernet card should be fine. it is gigabit. here is what it
says when I type in "sudo ethtool eth0":

     Settings for eth0:
      Supported ports: [ TP ]
      Supported link modes:   10baseT/Half 10baseT/Full
                              100baseT/Half 100baseT/Full
      Supports auto-negotiation: Yes
      Advertised link modes:  10baseT/Half 10baseT/Full
                              100baseT/Half 100baseT/Full
      Advertised auto-negotiation: Yes
      Speed: Unknown!
      Duplex: Unknown! (255)
      Port: Twisted Pair
      PHYAD: 1
      Transceiver: internal
      Auto-negotiation: on
      Supports Wake-on: pumbag
      Wake-on: g
      Current message level: 0x00000001 (1)
      Link detected: no

I am really confused and find no solution on my own. Any suggestion
would be greatly appreciated. I will wait online and provide any
additional information if you need.
Discuss-gnuradio mailing list
sorry for the late response, I have been working on ubuntu for several
days. Thank you for your reply. I just tried this command and nothing
happened, I got the same result as previous.
Could the ethernet card be too new for usrp2 to recognize? I am confused
because I have done every step mentioned in build guide and ran grc well.

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]