[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Need help in emergency for the fpga image

From: Matthias Wilhelm
Subject: Re: [Discuss-gnuradio] Need help in emergency for the fpga image
Date: Wed, 5 Jan 2011 10:41:13 +0100

Hello Gabriel,

there are many possible reasons why it wouldn't work, but in my experience it 
is most likely an issue with your SD card. 

- Did you put both the firmware and the FPGA bitstream on the SD card? Do they 
have matching versions?
- What SD card are you using? SDHC cards do not work, and the USRP2 seems to 
like 2GB cards (only?). When in doubt, use the SD card provided with the USRP2.
- Did you write the images directly to the beginning of the card without 
filesystem. You have to use /dev/sdX or the likes instead of 
/dev/sdX{1,2,3,4,...}. There are also graphical tools to flash the card 

There is also some info here if you haven't found it yet:

The second LED lights up when the firmware has successfully initialized the 
lowest level the device (before the ethernet handlers), so without it you will 
definitely not be able to find the USRP2. The first one just shows that it is 
powered up. 


Am 04.01.2011 um 19:29 schrieb Gabriel Morel:

> Hello everyone, I must find a way to compile the FPGA project for the USRP2 
> to continue my Masters. I use ISE 12.1
> and the top project u2_rev3 in the repository 
> git://ettus.sourcerepo.com/ettus/fpga.git using all the files in different 
> makefile.
> The compilation works well and I get the bin file of 842Kb. But during the 
> test, only one of the lights glow 
> and the computer does not see the radio.  Is there someone who can reproduce 
> this bug and help me find 
> an answer?
> Gabriel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]