[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Confusing uO Errors

From: Neil Bedwell
Subject: [Discuss-gnuradio] Confusing uO Errors
Date: Wed, 5 Jan 2011 10:47:05 -0500

I am having overruns that I cannot get figured out, and I am on a time
crunch to get this resolved.  Any help would be appreciated.

I seem to get uO's that appear irregularly, maybe every 20 seconds or so on

Script in Python: 
USRP with 2 TVRx boards -> Decimation set to 64 (1MHz BW, also tried 128,
with same result) -> Split Stream -> Store samples as two interleaved I/Q
files (4MB/s per file)
That data is what I expect out, so I don't suspect that the Python code is

Core2 Duo >2GHz per core (runs at 1GHz while executing)
Ubuntu 10.04 fresh install on Ext4 hard drive (Also tried 10.10, and have
tried AHCI settings to both On and Compatibility in BIOS)
USB benchmark succeeds at 32MB/s (8MB/s should not be an issue)
Latest GNU Radio from git (also tried 3.3.0)
High-speed hard drive, more than capable of 8MB/s writes (HD light only
flashes every few seconds when script is running)
I have tried playing with fusb_block_size/nblocks, but don't know a good
configuration to set, and haven't had luck reducing the uO's

What else can I try?
Are there buffer sizes that I can increase on the computer so that there is
room during the hard drive block writes?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]