[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP2 connection problem

From: mehmet kabasakal
Subject: [Discuss-gnuradio] USRP2 connection problem
Date: Mon, 10 Jan 2011 10:56:15 +0200

Hi everyone,
I am using USRP2 on ubuntu 10.10. When i try to run it with grc i got the this message,

Traceback (most recent call last):
  File "/home/mehmet/top_block.py", line 46, in <module>
    tb = top_block()
  File "/home/mehmet/top_block.py", line 29, in __init__
    self.usrp2_sink_xxxx_0 = usrp2.sink_32fc()
  File "/usr/lib/python2.6/dist-packages/gnuradio/usrp2.py", line 1137, in sink_32fc
    return _usrp2.sink_32fc(ifc, mac)
RuntimeError: No USRPs found on interface eth0

then i run ifconfig eth0 command then i got,

address@hidden:~$ sudo ifconfig eth0
[sudo] password for mehmet:
eth0      Link encap:Ethernet  HWaddr 60:eb:69:29:bb:c8 
          inet6 addr: fe80::62eb:69ff:fe29:bbc8/64 Scope:Link
          RX packets:10416 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2112887 (2.1 MB)  TX bytes:324570 (324.5 KB)
          Interrupt:48 Base address:0x4000

finally i tried find_usrps but again no response,

address@hidden:~$ sudo find_usrps
No USRP2 found.

I have checked if i install sdcc compiler from synaptic package manager and it seems it is installed.
I use the ethernet cable that comes with usrp2 in the package. then i changed the ethernet cable.
I used the one that is for internet connection but it didn't work.

The screenshot of the basic grc problem is attached.

Thanks for your help.


Attachment: Screenshot.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]