[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] wbx - usrp_benchmark_usb.py failed at testing 4MB

From: Howard Wong
Subject: Re: [Discuss-gnuradio] wbx - usrp_benchmark_usb.py failed at testing 4MB/sec
Date: Tue, 11 Jan 2011 14:18:23 +0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101207 Thunderbird/3.1.7

I get the same problem with this one,
using ubuntu 10.10,  and a DBSRX, WBX 

the single DBSRX works but it fails with the WBX.

So far, I have tried another two computers with ubuntu 9.10 fresh installation.
but exactly the same problem.
Is anyone having the same issue on WBX?
Kyle Zhou wrote:

In order to use WBX, I install git repo on my ubuntu 9.04.
When I do usrp_benchmark_usb.py, it goes well with 2MB test, but failed at
4MB showing device busy error.
The output is attached below. I tried other daughter boards (RF2400), no
problem. So I guess it is related to the WBX.

Testing 2MB/sec... usb_throughput = 2M
ntotal    = 1000000
nright    = 999156
runlength = 999156
delta     = 844
Testing 4MB/sec... usrp_open_interface:usb_claim_interface: failed interface
could not claim interface 1: Device or resource busy
usrp_basic_tx: can't open tx interface
Traceback (most recent call last):
  File "./usrp_benchmark_usb.py", line 106, in <module>
    main ()
  File "./usrp_benchmark_usb.py", line 96, in main
    ok = run_test (rate, verbose)
  File "./usrp_benchmark_usb.py", line 63, in run_test
    usrp_tx = usrp.sink_s (0, tx_interp)
  File "/usr/local/lib/python2.6/dist-packages/gnuradio/usrp/usrp_swig.py",
line 2741, in sink_s
    return _usrp_swig.sink_s(*args, **kwargs)
RuntimeError: can't open usrp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]