[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] UHD won't work with GRC

From: Fabian Klaes
Subject: Re: [Discuss-gnuradio] UHD won't work with GRC
Date: Fri, 21 Jan 2011 14:02:05 +0100

I first tried make distclean and the installation went fine, but when I tried to start the GRC, following window showed up: http://tinypic.com/r/dq671d/7 containing the error message "Cannot import gnuradio. Are your PHYTONPATH and LD_LIBRARY_PATH set correctly?"
I then tried git clean -dfx and rebuilding from scratch (for UHD and GNUradio).
Installation for UHD (worked):
git clone git://code.ettus.com/ettus/uhd.git
cd uhd/host
mkdir build
cmake -DCMAKE_INSTALL_PREFIX=/opt/uhd ../

make test
sudo make install

uhd_find_devices and uhd_usrp_probe works fine now, so i figured that the installation of UHD was successfull

Installation for GNUradio (error at ./configure):
git clone git://gnuradio.org/gnuradio.git
git branch --track next origin/next
git checkout next
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:${PKG_CONFIG_PATH} #just to be sure ...
BOOST_PREFIX=/opt/boost_1_37_0 #echo $BOOST_PREFIX returned nothing in the first place, so i figured it could help
#I also put both uhd paths in ld.so.conf and ran sudo ldconfig, but it didn't help
./configure --with-boost=$BOOST_PREFIX  --enable-gr-uhd

Now following error showed up:
checking for UHD... no
gr-uhd requires libuhd 2.x.x
configure: error: Component gr-uhd has errors; stopping.

I did: find |grep libuhd and got:

so I added /opt/uhd/lib/ and /home/fs/gnuradio-git/uhd/host/build/lib/ to ld.so.conf and ran sudo ldconfig (as said above). I then also tried to set LD_LIBRARY_PATH (see above again) but still the same error.
I also tried to git clone from http://gnuradio.org/git/gnuradio.git (described in [1]) instead of git://gnuradio.org/gnuradio.git (described in [2])

I don't know what to do next and would appreciate any help (again). I would be really happy if we could get this going.


[1] http://gnuradio.org/redmine/wiki/1/UbuntuInstall
[2] http://ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki

On Thu, Jan 20, 2011 at 5:13 PM, Josh Blum <address@hidden> wrote:

> And the (probably) critical part causing the error:
> make[6]: *** Keine Regel vorhanden, um das Target »usrp_prims.cc«,
>   benötigt von »_usrp_prims_la-usrp_prims.lo«, zu erstellen.  Schluss.
> make[6]: *** No Rule given, for making Target »usrp_prims.cc«,
>   needed by »_usrp_prims_la-usrp_prims.lo«.  Ending.
> If you (or anyone else) got another hint on how to solve this i would be
> really glad.

Sometimes autotools gets confused when there are many changes to the
build system. Try make distclean, and if not working: git clean -dfx
(wipes everything). and rebuild from scratch.


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]