[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Run problems with latest UHD build

From: Alexandru Csete
Subject: Re: [Discuss-gnuradio] Run problems with latest UHD build
Date: Sun, 23 Jan 2011 11:43:47 +0100

On Sun, Jan 23, 2011 at 8:11 AM, john <address@hidden> wrote:
> Ubuntu 10.4
> I (intended) to pull over the latest GIT and did the usual procedure
> which has worked before i.e.
> cmake ../
> make
> make test
> sudo make install
> however, when I run the GNURadio Companion as before, I now get:
> Traceback (most recent call last):
>  File "/home/john/lsb_tx_bpf.py", line 14, in <module>
>    from gnuradio import uhd
>  File
> "/usr/local/lib/python2.6/dist-packages/gnuradio/uhd/__init__.py", line
> 27, in <module>
>    from uhd_swig import *
>  File
> "/usr/local/lib/python2.6/dist-packages/gnuradio/uhd/uhd_swig.py", line
> 6, in <module>
>    import _uhd_swig
> ImportError: 
> /usr/local/lib/python2.6/dist-packages/gnuradio/uhd/_uhd_swig.so: undefined 
> symbol: _ZNK3uhd12meta_range_tIfE4clipERKfb
> I am sure that the error is all mine but would appreciate someone
> pointing out where I am going wrong?

Hi John,

There have been some API changes in the latest UHD announcement so you
have to rebuild GNU Radio with the new UHD libs (make clean, make,
sudo make install).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]