[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Discuss-gnuradio] problem building next branch

From: Ulrika Uppman
Subject: RE: [Discuss-gnuradio] problem building next branch
Date: Mon, 24 Jan 2011 16:44:30 +0100

 Doh! :) 

I didn't think I had an old build on that location, but I did. It was stupid of 
me not to try the standard solutions before, but "make distclean" did the trick 
and everything works fine now. Thanks a lot for the quick reply!

Best regards,

> -----Original Message-----
> From: Tom Rondeau [mailto:address@hidden 
> Sent: Monday, January 24, 2011 3:49 PM
> To: Ulrika Uppman
> Cc: address@hidden
> Subject: Re: [Discuss-gnuradio] problem building next branch
> On Mon, Jan 24, 2011 at 7:02 AM, Ulrika Uppman 
> <address@hidden> wrote:
> > Hi,
> > I'm trying to build gnuradio with uhd on my system with 
> Ubuntu 10.4. When building master branch everything seems ok, 
> but I have some problems building the next branch of 
> gnuradio. In gr-msdd6000/src/ there is an error where the 
> compiler complains on "./python/msdd.cc: No such file or directory".
> >
> > I tested to revert to the latest revision that passed the 
> build-test at hudson 
> (31bbbec88b19230eb37b197d7623c3671e57837e) but then I got a 
> version mismatch with the latest uhd master branch.
> >
> > I also tried to go back 1,2,...,5 commits of the next 
> branch of the gnuradio code, but I got the same problem and 
> didn't go any further on this reverse path. Instead I tried 
> to fix the problem and replaced "python/msdd" with 
> "python/msdd_rs" (which exist) in the Makefile.swig.gen file. 
> This seemed to fix this problem, but only gave me another one 
> in gr-atsc/src which wasn't that quick-fixable.
> >
> > Have anyone else had any problems building the next branch 
> with uhd? 
> > (I have myself built this branch successfully several times before, 
> > but doesn't seem to have any luck on the latest revisions.)
> >
> > Best regards,
> > Ulrika
> Have you tried doing a "make distclean" and then restarting 
> the build (./bootstrap && ./configure && make)?
> Also look at the "Dealing with old build problems" here:
> http://gnuradio.org/redmine/wiki/gnuradio/BuildGuide
> Tom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]