[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] undefined Symbol with UHD in GRC

From: Christian Schroeder
Subject: Re: [Discuss-gnuradio] undefined Symbol with UHD in GRC
Date: Tue, 12 Apr 2011 08:16:12 +0200
User-agent: Mozilla-Thunderbird (X11/20100328)

Josh Blum wrote:
> On 04/11/2011 05:33 AM, Christian Schroeder wrote:
>> Hello,
>> I am just trying to move to UHD. For this I installed the gnuradio
>> master branch to a custom location in my home. Moreover, the uhd
>> software (release 003.000.001 built from source) is at non-default
>> location in /opt/uhd.
>> ./configure, make and make install worked without problems, but when
>> running a simple flowgraph in grc using a uhd block, I get an error
>> message (see below) when importing uhd.
>> Maybe I am missing an environment variable at this point?
>> $LD_LIBRARY_PATH=/opt/uhd/lib/:/home/csc/Software/gnuradio_git_master_2011-03-28/lib/
>> $PYTHONPATH=/home/csc/Software/gnuradio_git_master_2011-03-28/lib/python2.6/site-packages
> Also set the PKG_CONFIG_PATH to help your gnuradio configure find the
> uhd in /opt

This I did, of course. Otherwise the gr-uhd would not have ben
configured. I also set UHD_LIBS and UHD_INCLUDEDIR

>> A reply from Josh to a similar posting did not point me to the solution.
>>  Libraries are there, but I did not find the symbol in gr-uhd/uhd_swig.i
>> as mentioned.
>> OS is Ubuntu karmic 9.10 64Bit.
>> Any hint is be appreciated.
> Make sure that you are building the latest master branch for UHD and for
> Gnuradio, and then you dont have multiple installs or something. I'm
> sure this is just an issue of a stale branch/install.

I checked out both again from git and installed to /opt/uhd and
/opt/gnuradio, respectively, after 'make uninstall' for the other
'./configure', 'make' and 'make install' did not stop with error, uhd
blocks are available in GRC, but the symbol is still not there.
The symbol _ZN3uhd4usrp10multi_usrp9ALL_GAINSE which causes the error is
in the libgnuradio-uhd.so and also in the libuhd.so
I'm sort of puzzeled at this point.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]