[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Build/install on Ubuntu x64 10.10 today

From: Arturo Rinaldi
Subject: Re: [Discuss-gnuradio] Build/install on Ubuntu x64 10.10 today
Date: Tue, 12 Apr 2011 22:54:48 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv: Gecko/20110303 Lightning/1.0b2 Thunderbird/3.1.9

Il 12/04/2011 20:58, Andrew Hofmaier ha scritto:
Performed the following routine:

commented all path lines from .bashrc.  (I had previously tested it with both dist-packages and site-packages).
ran sudo ldconfig
ran sudo ldconfig again
recieved the same error message (ImportError: /usr/local/lib/libgnuradio-core-3.4.0git.so.0: undefined symbol: _ZTIN5gruel12msg_accepterE)

Went back to the source (fresh git download this AM) and:
make uninstall
./configure --enable-gr-uhd
make check
sudo make install
sudo ldconfig
logged out / logged in (just for kicks)

I got the same errors (cannot find Gnuradio and the import errors)

Then, I tried arturo's method.
make uninstall
sudo checkinstall

This gave me the error: "dpkg-db: parse error, in file '/var/tmp/tmp.hX5IvZ8xr3/package/DEBIAN/control' near line 10 package 'gnuradio':
 empty value for version"

Any further comments?

_______________________________________________ Discuss-gnuradio mailing list address@hidden http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
i downloaded the latest git snap this afternoon and the installation was quite smooth. I'll list my procedure step by step :

+sudo apt-get build-dep gnuradio
+sudo apt-get install libboost1.42-all-dev python-qwt5-qt4
+download and install the following file (the uhd driver)



+git clone http://gnuradio.org/git/gnuradio.git
+sudo make install (or checkinstall)

about the checkinstall error you have to change the value version which is empty. So when asked digit "3" and insert just for example 1:3.4.0-git.

+sudo ldconfig
+/usr/local/libexec/gnuradio/gcr_setup_freedesktop install (for shortcuts in the start menu and the file associations)

you can add this latest directory in your path as

export PATH=$PATH:/usr/local/libexec/gnuradio

for the "gcr_setup_freedesktop" script, then logout and login. It worked very fine for me. No problems at all. Please ask me again if you have troubles...follow also Marcus suggestion by purging any other gnuradio installation if existing.....

Regards, Arturo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]