[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Error when using UHD, GRC

From: Mark Colin
Subject: Re: [Discuss-gnuradio] Error when using UHD, GRC
Date: Wed, 27 Apr 2011 14:34:02 -0700 (PDT)


     OK, the uhd_find_devices --args="type=usrp1" is working, there's no device discovery error message, but when I tried to run the uhd_usrp_probe --args="type=usrp1" the uhd_usrp_probe broke down giving a nice error message:

"uhd_usrp_probe.exe has encountered a problem and needs to close.  We are sorry for the inconvenience."

If I disconnect from the Internet (I have internet connection on PPPOE) then I don't get any error when running uhd_find_devices.exe instead when I run uhd_usrp_probe.exe I get the mentioned error. I even tried to disable Local Area Network, and VirtualBox Network, but the error is there.

I tried many packet sniffer (TCP, UDP) programs but there's no data transfer (I couldn't find any packet sent by UHD) when running uhd_usrp_probe --args="type=usrp1" therefore it might be some error in the test program uhd_usrp_probe before sending out any packet.

What could be the problem?


Best Regards,

From: Josh Blum <address@hidden>
To: Mark Colin <address@hidden>
Cc: address@hidden
Sent: Wed, April 27, 2011 3:13:39 AM
Subject: Re: Error when using UHD, GRC

On 04/26/2011 04:59 PM, Mark Colin wrote:
> Hi Josh,
>    I have an USRP1 working on USB therefore it shouldn't give such kind of
> errors like "Error: An existing connection was forcibly closed by the remote
> host"?

Sorry, I missed that it was a USB based USRP. Even though its USB, the
discovery logic still tries to send out broadcast packets to your
network interfaces. (I am assuming that this error is a network issue.)

I think if you add these arguments, the discovery logic wont attempt to
search the network.

uhd_find_devices --args="type=usrp1"
uhd_usrp_probe --args="type=usrp1"

It still might be worth it to fix the issue. Maybe disable a few extra
network interfaces (or virtual ones like VPN). I have no idea, so I am
curious as to what might cause this.


I assume you did do this:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]