[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Split-function implementation of 802.11g OFDM PHY

From: Nemanja Trecakov
Subject: Re: [Discuss-gnuradio] Split-function implementation of 802.11g OFDM PHY and MAC on USRP2
Date: Mon, 22 Aug 2011 16:07:35 +0100

Hi list,

Thank you for your response!

>You must tell your windows where your make/gmake is by setting the 

>environment variable PATH

>to C:\Program Files\GnuWin32\bin (in your case)

@Patrik & Josh: I added this to my path, and this helped. Now is 
'make/gmake'-command recognizable.

>Evidently one also needs 'head' as well:


@Alex: I installed CoreUtils from the link (Complete package, except sources), 
and it solved the 'head'-problem.

> Looks like a prefix is getting appended to a full/non-relative path. Its
> got to be an issue in this line and lines like it in the Makefiles.srcs
> files:
> FIFO_SRCS = $(abspath $(addprefix $(BASE_DIR)/../fifo/, \
> -josh

@Josh: Yes, this was indeed the problem. I tried to change the line, but then I 
got a new error 'missing separator. Stop.’ which means that there were some 
irregular spaces between the commands in the file. After many rounds with 
trying to find out what is wrong and reading in the make-manual (which you get 
with the installation on C:\Program 
Files\GnuWin32\doc\make\3.81\make-3.81\make.pdf), I found out that the main 
problem is that you need to divide the lines ONLY WITH ENTER from the last 
character in the previous line, not with tabs or spaces. I used WordPad to edit 
my Makefiles.srcs, where the break between the lines looks the same in case of 
line break with enter or some extra spaces and enter.     

So the line was changed to:

FIFO_SRCS = $(abspath/../../fifo/, \

However, what is really interesting is that I didn't have to change the all 
paths in all of the 'Makefiles.srcs', only in some, which is quite illogical.

So this problems are now solved, but I got a new one. 

Error output:
make: *** No rule to make target `)', needed by `C:/USRP2_fpga_NEMO/usrp2/top/US
RP2/build/u2_rev3.xise'.  Stop.

Anyone suggestions?

Thank you in advance!

Nemanja Trecakov

reply via email to

[Prev in Thread] Current Thread [Next in Thread]