[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] TVRX2+USRP (serial > 500) 'invalid EEPROM content

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] TVRX2+USRP (serial > 500) 'invalid EEPROM contents' problem
Date: Tue, 13 Sep 2011 08:05:38 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101027 Fedora/3.0.10-1.fc12 Thunderbird/3.0.10

On 13/09/11 02:54 AM, Dmitry Shatskiy wrote:
> Thanks for your reply Josh,
> So the instructions are:
> (1) Use the script
> OR
> (2) - run "git clone http://gnuradio.org/git/gnuradio.git";,
> - Follow the Gnuradio build guide:
> http://gnuradio.org/redmine/projects/gnuradio/wiki/BuildGuide,
> - check the dependencies and make sure that gr-uhd is enabled in
> the Gnuradio source tree.
> I'm positive I did (1) on one of our systems and (2) on another one.
> To the letter. Neither of them work.
> I believe the libusrp1-gnuradio driver was installed along with the
> gr-uhd one.
> Is there a way to figure out which library is being used by UHD?
> Is there a way to specifically tell UHD which source and sink blocks
> should be used?
> Thank you,
> Dmitry Shatskiy.
You're not understanding. If you use the "classic" API, rather than
UHD, you won't be able to
correctly deal with a TVRX2, since that card is supported *ONLY* with
the UHD API. Many of
the example programs, such as usrp_usb_benchmark.py, use the so-called
"classic" API. They
haven't been updated. It doesn't matter how up-to-date your UHD
installation is, the "classic APIed"
programs have no knowledge at all of UHD or any of the post-UHD
hardware that's out there.

If you want to check gross functionality of your TVRX2 card, you can use
"uhd_fft.py" to grab an
FFT spectrum off the card, and make sure that it's working.

If you want to produce your own flow-graphs, you'll have to use the "UHD
source" within GRC.
The "classic" USRP1 source won't work with the TVRX2 card, because
that card was released
*after* the classic API was deprecated and no longer being updated.

If you have an up-to-date Ubuntu system, then the 'build-gnuradio'
script should take care of installing
and building everything you need to make UHD-api "stuff" just work.
Including within
gnuradio-companion, "uhd_fft.py", etc. But none of the "classic" API
examples will work with
TVRX2, or indeed many of the other post-UHD cards out there. Since
you're a new user, you have
no massive reams of code that need to maintain compatibility with the
"old ways", so start learning
and using UHD.


Thanks for your reply Marcus and thank you for all the work you guys do to keep this project going.

As far as I've understood the problem is that old codes use so to say old sets of instructions disregarding changes in the hardware.
What is the best way to start learning UHD? So far trying to run uhd_fft.py I'm getting an error (there's more to that, it's just some last few lines):

   File "/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line 1856, in usrp_source
    return _uhd_swig.usrp_source(*args, **kwargs)
RuntimeError: LookupError: KeyError: No devices found for ----->
Device Address:

Dmitry Shatskiy.
The default device address in uhd_fft.py is for a USRP2/N210.  Try using the --address="type=usrp1"
  option.  Other options, use "uhd_fft.py --help".

Principal Investigator
Shirleys Bay Radio Astronomy Consortium

reply via email to

[Prev in Thread] Current Thread [Next in Thread]