[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] New build structure! (Warning #2)

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] New build structure! (Warning #2)
Date: Sun, 23 Oct 2011 22:02:02 -0400

On Sun, Oct 23, 2011 at 9:38 PM, Jordan Otomo <address@hidden> wrote:

I've tried the following:

$ cd gnuradio
$ git checkout next
$ git pull
$ mkdir build
$ cd build
$ cmake ../
$ make
$ make test
$ sudo make install

'make test' returns 0 failures, but when using the gr-digital blocks in GRC, I see the following error:

Traceback (most recent call last):
 File "/home/jotomo/Desktop/digital_rx_test.py", line 8, in <module>
   from gnuradio import digital
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/digital/__init__.py", line 34, in <module>
   from cpm import *
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/digital/cpm.py", line 27, in <module>
   from gnuradio import gr, blks2
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/blks2/__init__.py", line 37, in <module>
   exec "from gnuradio.blks2impl.%s import *" % (f,)
 File "<string>", line 1, in <module>
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/blks2impl/cvsd.py", line 24, in <module>
   from gnuradio.vocoder import cvsd_vocoder
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/vocoder/cvsd_vocoder.py", line 24, in <module>
   _cvsd_vocoder = swig_import_helper()
 File "/usr/local/lib/python2.7/dist-packages/gnuradio/vocoder/cvsd_vocoder.py", line 20, in swig_import_helper
   _mod = imp.load_module('_cvsd_vocoder', fp, pathname, description)
ImportError: libgnuradio-core-3.4.1git.so.0: cannot open shared object file: No such file or directory

I get the same error when attempting to run the gr-digital examples. It seems that the wrong library is being imported because I have 'libgnuradio-core.so.3.5.0git' in /usr/local/lib.  Did I miss a configuration/un-installation step?  Any help would be greatly appreciated.


First, I just pushed another update the fixes the library naming scheme with cmake, so you'll want to pull from master again.

Second, you'll have to run 'sudo ldconfig' for the new library names.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]