[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Trouble with multiple installs or how i learned t

From: Paul M. Bendixen
Subject: Re: [Discuss-gnuradio] Trouble with multiple installs or how i learned to love make uninstall
Date: Wed, 26 Oct 2011 10:39:58 +0200

So I started today off by doing a make uninstall on the gentoo box. Then I went hunting.
As it turns out, I had to manually remove 3.5.0git files from a lot of the locations mentioned in the post concerning the WX Gui problem (http://lists.gnu.org/archive/html/discuss-gnuradio/2011-10/msg00355.html).

After removing these (along with a set of old installation files) i tried rebuilding. (after git clean -dfx; git pull)

Only error i got was:
.../git/uhd/firmware/zpu/lwip/lwip-1.3.1/src/include/lwip/memp.h:45: Warning: include file lwip/memp_std.h not found, perhaps you forgot to add its directory to INCLUDE_PATH?
with some warnings that:
 Warning: explicit link request to 'define' could not be resolved 
in the zpu firmware image.

It all works fine now, however due to moving around (i guess) i get a lot of warnings like:
Error: Connection between gr_interleave_0(0) and blks2_ofdm_mod_0(0) could not be made.
sink block id "blks2_ofdm_mod_0" not in block ids

in gnuradio-companion

When I use the modulation->gmsk it results in the error: 
self.blks2_gmsk_mod_0 = blks2.gmsk_mod(
AttributeError: 'module' object has no attribute 'gmsk_mod'

which is correct, it is now in digital.

Should this be fixed or are the XML files that grc uses not fully updated?
If so, should the git clean -dfx not have fixed this? 

The last example is the same on the xubuntu box (which was installed using the new build-gnuradio script).

Maybe I should start splitting this out into different mails?


2011/10/25 Tom Rondeau <address@hidden>
On Tue, Oct 25, 2011 at 12:19 PM, Paul M. Bendixen <address@hidden> wrote:

It seems it might be a good idea if it were possible to uninstall gnuradio propper.

I currently have two systems faling (hard) using the new build.

My gentoo box (configured using cmake in another thread)
gives me the error :
ImportError: libgruel-3.4.2git.so.0: cannot open shared object file: No such file or directory
Whenever i try
from gnuradio import digital.

funny part is: I never succeeded in installing 3.4.2, so I don't blame it for not finding it.

I tried doing a manual ldconfig, but it didn't seem to do the trick.

On an ubuntu machine (xubuntu to be specific) using the build-gnuradio script, most of the digital schemes fails
due to the reallocation of packets to digital. This includes stuff that should be updated.

Is it possible that the python stuff does not get properly updated and is there any way to fix this?

Downgrading, by adding a "git checkout v3.4.2" fixes makes the build run fine again.

On both systems the building of the system is without problems.

make uninstall does work and removes all of the GNU Radio files from the system. The twist that you need to remember is that you have to do it BEFORE upgrading to a new version. The 3.5 will try to uninstall it's stuff, which will be different from 3.4. So you have to have to run 'make uninstall' when you've configured for what's installed on your system. Then you can upgrade and shouldn't have any conflicts.

When you say that you didn't have 3.4.2 installed, do you mean that you never installed from master before? For the past few weeks, the master branch reflected the 3.4.2, so any installs will have that in their name.

You did help me find a bug in our cmake install, though. Some of our specially-built files are not being removed by uninstall.


• − − •/• −/• • −/• − • •/− • • •/•/− •/− • •/• •/− • • −/•/− •/• − − •− •/− − •/− −/• −/• •/• − • •/• − • − • −/− • − •/− − −/− −//

reply via email to

[Prev in Thread] Current Thread [Next in Thread]