[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Error while using uhd usrp blocks

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] Error while using uhd usrp blocks
Date: Mon, 6 Feb 2012 11:32:32 -0500

On Fri, Feb 3, 2012 at 1:13 PM, Ben Hilburn <address@hidden> wrote:
Tom - maybe you can correct me if I'm wrong, here?

I think you are asking about the changes Tom made to the general loop formula, the details of which you can find here:



Ben, yep, that should explain it a bit better.

Shashank, also, the theta value is a constant rotation for the constellation. If your QPSK symbols, say, are located at (+/-1) + j(+/-1), the rotation is 45 degrees (I think that's how the default slicing works) as described in the block's documentation:

 theta any constant phase rotation from the real axis of the constellation


On Thu, Feb 2, 2012 at 7:14 AM, shashank gaur <address@hidden> wrote:

First of all Thank you very much for your support
I was able to run the program on two different USRP and it was successful.

But still I have some new problems. Actually I am doing my masters project on gnuradio and usrp.
I am trying to make a BPSK transmitter and receiver(Attached GRC Files), then use it further in my project. My mentor suggested to use MPSK Receiver for the receiver part but I am not sure about Loop Bandwidth and Theta as the solution my mentor gave is for the old version of gnuradio. Can you help me with understanding these parameters?
Right now when I start my receiver program on a usrp the number plot varies around 0.5 (which I guess is normal when there is no transmission) but when I start transmitter the value goes high to 0.6 or 0.7 (It should be lower than 0.3).
I am using following parameters for the same

M = 2 for BPSK

Theta = 0 (I was not sure about this so I put it 0)

Loop Bandwidth= ????? (I dont knw what to put here)

Min Freq = -0.05

Max Freq = 0.05

Mu = 0.5

Gain Mu = 0.001

Omega = 8

Gain Omega = 0.000001

Omega Relative Limit = 0.0001

Also I tried to use Costas loop and Clock Recovery MM with same parameters but they are also not working.
It would be great help if anyone can help me understand these parameters.

Shashank Gaur

On Fri, Jan 27, 2012 at 9:38 PM, shashank gaur <address@hidden> wrote:
Hello all
Thank you very much for such prompt response.
@Marcus: I understand the problem now and will try to implement the Rx and Tx on different USRP on Monday. The weeekend has already started here in France.
@Andrew: I will also get back with exact result of the commands but what I remember for uhd_find_devices the result was the device address that is 4d9de875 and in uhd_usrp_probe it detected all the available RX and Tx (it has Flex900).
Apologies for the delay but cannot access the usrp before Monday. The mentor doesnt allow me to have usrp at home. Hope you understand
Thanks again for your time
shashank gaur

On Fri, Jan 27, 2012 at 9:18 PM, Marcus D. Leech <address@hidden> wrote:
On 27/01/12 03:00 PM, Andrew Davis wrote:
Type " uhd_find_devices " into console, then " uhd_usrp_probe " then give us the results, and the code for the program you're trying to run.

On Fri, Jan 27, 2012 at 9:39 AM, shashank gaur <address@hidden> wrote:

I am simply trying to build a transmitter and receiver for bpsk modulation and demodulation using mpsk receiver at receiving end. I am using USRP1 (Flex900 Daughter boards) with Gnuradio Companion 3.5.0rc0 on Ubuntu 10.10.

When I run either (trransmitter or receiver) of any grc applications first the grc executes it successfully and when I run other the grc gives following error.
linux; GNU C++ version 4.4.5; Boost_104200; UHD_003.003.001-8ff8f20

Traceback (most recent call last):
  File "/home/sunny/Examples/top_block.py", line 105, in <module>
    tb = top_block()
  File "/home/sunny/Examples/top_block.py", line 40, in __init__
  File "/usr/local/lib/python2.6/dist-packages/gnuradio/uhd/__init__.py", line 93, in constructor_interceptor
    return old_constructor(*args, **kwargs)
  File "/usr/local/lib/python2.6/dist-packages/gnuradio/uhd/uhd_swig.py", line 2003, in usrp_sink
    return _uhd_swig.usrp_sink(*args, **kwargs)
RuntimeError: LookupError: KeyError: No devices found for ----->
Device Address:
    serial: 4d9de875

I think it has something to do with USRP UHD Source/Sink block parameters.
Either the grc is not able to recognize the daughter board or there is problem with hardware. may be I am wrong.
Please help me to recognize the error.
Thank you very much for your time
Shashank Gaur

Discuss-gnuradio mailing list

_______________________________________________ Discuss-gnuradio mailing list address@hidden https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Just so we're clear here.  If you're trying to run your RX and TX as two separate processes, against the
  same USRP1, that won't work.    You'll need to have two independant USRP1s, or collapse your RX and
  TX into a single combined program--only one process can have a "handle" against each USRP1 at a time.

Principal Investigator
Shirleys Bay Radio Astronomy Consortium

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]