[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Three different USRP2 nodes are transmitting with

From: Ben Hilburn
Subject: Re: [Discuss-gnuradio] Three different USRP2 nodes are transmitting with almost exactly 1 MHz frequency offset
Date: Thu, 9 Feb 2012 09:44:44 -0800

Nazmul -

Your version of UHD is from November 22nd.  Will you try updating your UHD install?

I'm not sure how you installed, or how familiar you are with git / Linux  - here is a quick command list, assuming you used Git to checkout the code to begin with, and it is in a directory called uhd.git/

$ cd uhd.git
$ git checkout master
$ git remote update; git pull
$ rm -rf build
$ mkdir build; cd build
$ cmake ../ && make

Let us know how it goes!


On Wed, Feb 8, 2012 at 8:52 PM, Nazmul Islam <address@hidden> wrote:
Thanks for the reply, Jason. The uhd_usrp_probe --version command gave the following result:

linux; GNU C++ version 4.4.5; Boost_104200; UHD_003.004.000-71810ad


Do I have to download the latest UHD image? The image that I am using right now was downloaded by one of my colleagues and I think that he did it recently.

Also, I tried running the benchmark_tx and benchmark_rx codes with a 1 MHz frequency offset input, i.e., I gave the following commands:

./benchmark_tx.py -f 2.4G -r 1M -m gmsk -a "addr ="

./benchmark_tx.py -f 2.401G -r 1M -m gmsk -a "addr ="

Since the uhd_fft.py and the my lab spectrum analyzer show a 1 MHz frequency offset, I assumed that the above commands would work. Unfortunately, this did not help either!

Suggestions will be very appreciated.



On Wed, Feb 8, 2012 at 7:37 PM, Jason Abele <address@hidden> wrote:
On Wed, Feb 08, 2012 at 06:39:24PM -0500, Nazmul Islam wrote:
> Hello,
> I am running the benchmark_tx.py codes and looking at the spectrum of the
> signals using uhd_fft.py. I am using the latest image of GNU radio
> (GNUradio 3.5) and I have XCVR2450 daughterboards. I ran the
> benchmark_tx.py code in three transmitter nodes and surprisingly, all of
> them are transmitting with 1 MHz frequency offset! I have attached two
> screenshots with the email (I hope that they go through). I give the
> following input parameters to run the benchmark_tx code.
> ./benchmark_tx.py -f 2.4G -r 1M -m gmsk -M 10 -a "addr ="
> Both uhd_fft.py and the spectrum analyzer of my laboratory show that the
> received signal is centered at 2.401 GHz. I varied the frequency to 2.45
> GHz, 2.41 GHz, but this 1 MHz frequency shift persists.
> When I run the benchmark_rx.py code at the receiver nodes, they don't
> receive/detect any packets (due to the frequency offset, I guess). I even
> tried to run the transmitter at 2.4 GHz and the receiver at 2.401 GHz.
> However, that did not help either!
> I will try to modify the control loop gain parameters using Tom's blogs
> suggestions and see if that helps. However, I am really surprised to see
> how all three different transmitter nodes can transmit with almost exactly
> 1 MHz frequency offset. Any suggestion will be appreciated.

Can you tell us which version of UHD you are using?
(uhd_usrp_probe --version)

We have heard reports of such an issue and my best guess is that it was
related to an accidental swap of I and Q in the XCVR2450 transmitter
code.  This went in after the 3.3.2 release and is fixed on latest UHD
master since 837437c65ce36d418cceb3df5b093f9497b3af5f


Muhammad Nazmul Islam

Graduate Student
Electrical & Computer Engineering
Wireless Information & Networking Laboratory
Rutgers, USA.

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]