[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] help with QAM demodulation

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] help with QAM demodulation
Date: Mon, 27 Feb 2012 10:31:15 -0500

On Mon, Feb 27, 2012 at 9:36 AM, Jeff Hodges <address@hidden> wrote:
Does anyone know if the QAM demodulator code is working properly?  I would like to get a QAM demodulator working for a symbol rate of 300ksym/s. I don't know whether I am just using the wrong parameters or if the blocks do not work properly, but I am not getting the results I expect.

To test the code out I am using the GRC. I have a vector source with a known data sequence running into the qam mod block and then the output of that into a QAM demod block. The output of the QAM demod is running into a Uchar to Float, and I am plotting the results on a WX GUI Scope.  I have the exact same settings on both the QAM mod and demod blocks.  The output I am seeing on the scope looks completely random. (I also tried other vector source data: When the input is 0x0F, repeating, the output I see is 00001010 repeating. But when I use 0x0E, the results are random again.)

I have also tried demodulating a real QAM signal with a known data sequence, also to no avail.

I have been working on this for about a month now and haven't had any success.  I have examined the underlying QAM.py and generic_mod, generic_demod codes, and they seem to be written properly. But I am not getting the expected results.

Any help with this problem or advice you can give will be greatly appreciated, and I will return the favor by helping out in any way that I can.

Thank you very much in advance,


It's been a while since I used the QAM mod/demod blocks. They are definitely not complete since there's no synchronization for them, yet, but since you are just working in simulation, this shouldn't be a problem.

What alphabet (M) size are you using with the QAM module? And the results for 0x0F look like the data is differentially encoded, so that might just be your problem there. 

Have you looked at the constellation? Does it look ok?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]