[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GR 3.5.1 & OSX

From: Michael Dickens
Subject: Re: [Discuss-gnuradio] GR 3.5.1 & OSX
Date: Sun, 4 Mar 2012 09:25:09 -0500

It looks like you have a mixed install, somehow, of MacPorts stuff; some older, 
some newer.  If you haven't done it recently, I'd recommend:

sudo port selfupdate
sudo port upgrade outdated

and, if that breaks, do:

sudo port clean outdated
sudo port -p upgrade outdated

and then report the issues on a MP ticket if a search on active tickets turns 
up nothing.  My guess is that doing the above will fit the issue. - MLD

On Mar 4, 2012, at 8:24 AM, Carles Fernandez wrote:

> Thanks for the hint. It seems that there is a problem with the
> libfreetype library:
> $  python
> Python 2.7.2 (default, Jan 21 2012, 15:35:05)
> [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import gtk
> Traceback (most recent call last):
>  File "<stdin>", line 1, in <module>
>  File 
> "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py",
> line 40, in <module>
>    from gtk import _gtk
> ImportError: 
> dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/_gtk.so,
> 2): Library not loaded: /opt/local/lib/libfreetype.6.dylib
>  Referenced from:
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/_gtk.so
>  Reason: Incompatible library version: _gtk.so requires version
> 15.0.0 or later, but libfreetype.6.dylib provides version 14.0.0
> I will try to fix this.  I will post the solution in case of success,
> maybe can be useful to others.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]