[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Rx dBoard has empty serial

From: Ben Hilburn
Subject: Re: [Discuss-gnuradio] Rx dBoard has empty serial
Date: Mon, 19 Mar 2012 12:35:20 -0700

Jan -

UHD supports calibration of all WBX boards.  The issue is that when you bought your WBX, we weren't burning serial numbers into that daughterboard.   The calibration routine requires a serial number, because it uses it to save / identify the calibration data.

All you need to do is burn a serial into your daughterboard.  UHD builds a utility called 'usrp_burn_db_eeprom' (host/build/utils), which you can use to set the serial of your daughterboard:

./usrp_burn_db_eeprom --unit=TX --ser=<serial>
./usrp_burn_db_eeprom --unit=RX --ser=<serial>

The serial you set can be any 9-digit ASCII string.  After you write new serials into your daughterboards, try the calibration again, and it should  work fine.


On Mon, Mar 19, 2012 at 9:40 AM, sirjanselot <address@hidden> wrote:

I replaced my WBX boards with rev 3 and it looks like its working now.
However, I would still like to be able to run the calibration routines on
the rev 2 versions.  Are you guys going to support this?

- Jan

sirjanselot wrote:
> My UHD version is UHD_003.004.000-325-g7e296167
> I opened up my USRP N210s and it seems like on each board it says two
> different rev numbers.
> On all boards it shows WBX Board Rev. 2 on the main board while on the
> connector board (the board with the RX and TX connectors on it) it says
> WBX-FE-Simple Board Rev 4.0.
> I think my boards are about a year old.
> I installed gnuradio and uhd this saturday.
> - Jan
> Marcus D. Leech wrote:
>> What version of UHD are you running? And what approximate age are
>> the WBX?
>> The Rev 3 WBX is somewhat different than Rev 2, so you need
>> to make sure that you have the latest host-side UHD and matching
>> firmware to properly support Rev 3 WBX.
>> There was a (transient) bug in
>> the calibration routines that was found last week, but it's fixed in the
>> most recent UHD host-side.
>> I used the cal routines on my USRP2+WBX
>> just this past weekeend and they worked just fine. So perhaps you have
>> the transiently-broken version of UHD.
>> Perhaps Josh can comment--I
>> don't have the GIT tags of the broken instance at my fingertips right
>> now.
>> On Mon, 19 Mar 2012 08:36:43 -0700 (PDT), sirjanselot wrote:
>> Hello,
>>> I reran the command for each individual USRP radio
>> connected.
>>> Two of my USRP N210s have this output:
>>> Error: RX
>> dboard has empty serial!
>>> One of my USRP N210 has this output:
>> Error: timed out waiting for TX and/or RX LO to lock
>>> and the
>> USRP1:
>>> Error: self-calibration is not supported for this
>> hardware.
>>> I can understand if the self-calibration is not supported
>> for the USRP1.
>>> However, for the USRP N210s I would like these
>> fixed. I ran uhd_usrp_probe
>>> and it seems like by dboard has a serial.
>> It says TX Dboard: A ID:
>>> WBX(0x0052).
>>> Is there a bug in the
>> calibration routines?
>>> Marcus D. Leech wrote:
>>>> When you have more
>> than one USRP device connected to your system, you really should be
>> explicit about which device you want to address, using the "--args"
>> option. For your N210 it would be "--args addr=192.168.X.Y" and for your
>> USRP1 it would be "type=usrp1" Otherwise, it just grabs the first USRP
>> device it finds. On Mon, 19 Mar 2012 07:47:03 -0700 (PDT), sirjanselot
>> wrote:
>>>>> Hello, I was
>>>> running the calibration routines for 3
>> USRP N210s and one 1 USRP
>>>> radio. I had them all connected
>> at once to my computer and all of a sudden it
>>>>> ow do I fix
>> this?
>>>> -left:#1010ff 2px solid; margin-left:5px; width:100%"> Does the
>> calibration routines run for all of them @ once, when I call the - Jan
>> _______________________________________________ Discuss-gnuradio mailing
>> list
>> _______________________________________________
>> Discuss-gnuradio mailing list
>> address@hidden
>> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

View this message in context: http://old.nabble.com/Rx-dBoard-has-empty-serial-tp33532071p33533072.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]