[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] unexpected LookupError using gpsdo

From: mleech
Subject: Re: [Discuss-gnuradio] unexpected LookupError using gpsdo
Date: Wed, 21 Mar 2012 10:16:00 -0400
User-agent: Roundcube Webmail/0.5.1

On Wed, 21 Mar 2012 21:23:39 +0800 (CST), Fengzhu FengzhuYe wrote:

I have bought two gpsdos and install them to my usrp n210. Then I congfiured them step by step according to the following link provided by ettus LLC http://files.ettus.com/uhd_docs/manual/html/gpsdo.html.
After all the things had done, I tried to retrieve the current GPS time by the "gps_time" sensor using the codes : " usrp->get_mboard_sensor("gps_time") ". The
compilation is ok and I executived the program. Then an unexpected LookupError occured :

Error: LookupError: Path not found in tree: /mboards/0/sensors/gps_time

I printed all sensor list and there are only two sensor "mimo_locked", "ref_locked". So I thought that means The gpsdo was not properly set so that the usrp didn't find any "gps_time" sensors. But when I executived the program "test_pps_input" at /usr/local/share/uhd/example. The pps seens all right. That means the gpsdo is ok. What's more, when I  used the reference sources provided by an external GPSDO by the code : 
It work well too.
Now I am confused . why is that happen? Was my gpsdo broken? All the two gpsdos have the same LookupError.
Thanks for your help.

Did you do the post-installation task:




Also, the "gps_time" is only available once the GPSDO is locked to a GPS satellite constellation--that's where it gets the time from (and the phase reference!).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]