[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] [USRP-users] Gnu Radio apps freezes (locks up)

From: Rickard Radio
Subject: Re: [Discuss-gnuradio] [USRP-users] Gnu Radio apps freezes (locks up)
Date: Thu, 29 Mar 2012 12:04:03 +0200

On Mar 29, 2012, at 3:26 AM, Tom Rondeau wrote:

> On Wed, Mar 28, 2012 at 10:02 AM, Rickard Radio <address@hidden> wrote:
>> Hi list,
>> After I upgraded to latest Gnu Radio 3.5.2, and latest UHD (and images), GR 
>> applications just freeze when running. No warnings, error messages or 
>> overflows etc. Just freeze.
>> A simple FFT plot directly on received samples from the USRPN210 just 
>> freezes after some seconds, or minutes (depending on the sample rate), 
>> although the load on the machine is not high. Need to kill GR-app and 
>> restart it, with the same problem occurring again.
>> This has never been a problem with earlier versions of GR/UHD, from about 6 
>> months ago.
>> The freezing happens quicker with high sample rate setting but also with 
>> lower, eventually. No overflows happen (which was possible to get before 
>> with too high sample rates or load, etc.)
>> The USRPN210 stops sending samples to the computer at the same moment as 
>> GnuRadio freezes (as observed on the system monitor).
>> Same thing happen on two identical laptops running Ubuntu 10.10 (also 
>> upgraded it from 10.04). Not sure if its a strict GnuRadio problem (since it 
>> worked before), UHD, or some problem with the Ubuntu Linux 10.10. It 
>> work(ed) flawlessly with another machine on OSX (before I tried to upgrade 
>> GR on it but then got stuck...) with identical UHD version and images.
>> Installation of UHD+GnuRadio with the automatic linux script runs without 
>> any problems, as before, no errors or warnings.
>> Any de-freezing help or clues appreciated!
>> Rickard
> Rickard,
> Just to be clear. When you install 3.5.2 from the tarball, it freezes.
> When you use the build-gnuradio, everything works fine?
> What's your machine?
> Tom


The installation with build-gnuradio script works just fine, as before (no 
Same result on both laptops, Acer Aspire TimelineX with i3 processors (2.26 
GHz),  running Ubuntu 10.10. 
I did not have this problem earlier with Ubuntu 10.04. Or on a Mac with OS X 
(with the source from git).  Could Ubuntu 10.10 cause the problem somehow?

Note: Halting/freezing only happens when running an application (with the N210) 
as a receiver. (Not transmitter, see below.)
The flow of receiving samples just halts after a while and the application 
freezes/halts (as a consequence). 
This happen sooner with high sampling rate (after a few seconds with 25MSPS), 
but eventually also with a bit lower sample rates. The CPU's are not 
overwhelmed (< 50%).   
It happens even if the UHD usrp source is connected directly to a null sink 
only. I do not get any overflows before the halt. 
In fact, I cannot even provoke a continuos stream of overflows since the 
reception just halts instead of producing overflows, which was the result 
 GnuRadio itself does not freeze as a whole (like the grc in the background), 
just the running application, which I then need to abort.  

Strangely enough, this "freezing/halting" does NOT happen when transmitting, 
correspondingly, even with high transmit sample rates such as 25 MSPS (or now 
possible even with 50MSPS with 8 bit/samples!). Then it works just fine - even 
without underruns (when using just a file source). 

/ Rickard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]