[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] help

From: mleech
Subject: Re: [Discuss-gnuradio] help
Date: Wed, 18 Apr 2012 15:58:09 -0400
User-agent: Roundcube Webmail/0.5.1

I'll also pessimistically point out that USB support in various versions of VMWare is unpredictably flakey and slow.  It *might* work just fine, or you might end up in a world of hurt.  This applies to all classes of USB device--and I've used quite a few under VMware 


On Wed, 18 Apr 2012 12:18:56 -0700, Nick Foster wrote:

On Wed, Apr 18, 2012 at 12:07 PM, Derrick Ho <address@hidden> wrote:
I am running ubuntu 11.10  on VMWARE FUSION (on OSX 10.7) and I have installed gnuradio 3.5.3
we have two laptops, each with their own usrp.  They are connected to the usrp via USB.
We are trying to sent a packet of data but there appears to be a usb problem.

The other computer runs the "./benchmark_tx.py" program and sends it to the usrp and sends it wirelessly to the air.

My computer has the same set up except I am using "./benchmark_rx.py" in an attempt to receive the stuff
from the "benchmark_tx.py"

It tells me that the USB is lacking the proper permissions.  The program begins running and none the the data is received.

What can be done about the permissions problem?

I have tried installing ubuntu as a separate partition on my mac, by following the instructions on the ubuntu website.  It doesn't work, so VMWARE fusion is the only way I can get ubuntu to work.

I've tried installing gnuradio 3.3.3 via macports (on an OSX 10.6 parition). when running "./benchmark_rx.py -R B -f 2.45G" I get a different error.  A real time scheduling error.  No idea what that means.

Tried adding sudo (ie. "sudo ./benchmark_rx.py -R B -f 2.45G") and found a different error.  It claims that module gnuradio does not exist.

I've checked the ".profile" file that macports created, and added the paths specified on this website

i've tried running python in terminal and entering "from gnuradio import gru" and it doesn't complain about anything.

I would really appreciate some help.  Hope to hear back from you soon
http://files.ettus.com/uhd_docs/manual/html/transport.html#usb-transport-libusb should help you out.

--Derrick Ho

Discuss-gnuradio mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]