[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] issues running usrp2_fft.py

From: Sanat Gulvadi
Subject: Re: [Discuss-gnuradio] issues running usrp2_fft.py
Date: Thu, 3 May 2012 12:12:40 +0200

I actually came across the FAQ that I should be running uhd_fft instead. Don't know how I missed it before.
Thanks anyway.


On Thu, May 3, 2012 at 12:11 PM, Sanat Gulvadi <address@hidden> wrote:
Greetings list,

I have hardly ever used gnuradio. But I want to use it for the usrp2_fft.py to use as a sort of spectrum analyzer. I installed gnuradio with the script created by Marcus Leech for ubuntu.

Upon running "usrp2_fft.py -f 2.45e9 -d 16 -g 20" I get a whole list of errors at the bottom of which is

RuntimeError: NO USRPs found on interface eth0

The line before the Traceback (most recent call last): reads

eth0: socket: Operation not permitted

 I ran sudo chmod +s /usr/bin/usrp2_socket_opener as posted in response to one of the previous queries but I still get the same error. The thing is that the device is actually connected on the eth1 interface. So if I run the same command with an additional -e eth1 it's the same error again except for the eth1.
I have Ubuntu 11 on my machine. It has the latest gnuradio and UHD installed from the script and the latest Firmware and FPGA images. The hardware I am using is a USRP2-Rev4 with RFX2400 daughterboard. The problems I described above, I am facing on another machine that has the exact same setup except for Ubuntu 10 instead of 11.

Another question is, the build_gnuradio script asks you to set your PYTHONPATH to /usr/local/lib/python2.7/dist-packages. Which I did, but I was getting errors like    
        from gnuradio import usrp2

ImportError: cannot import name usrp2
I have made sure that the packages are installed by running dpkg --get-selections | grep gnuradio  and it shows me the python-gnuradio-usrp2 package as installed.
I found that after exporting the PYTHONPATH to /usr/lib/python2.7/dist-packages instead, it runs but gives me the error above. But each new terminal I open, I have to run that export command. Is there a permanent solution ? Should I add the line export PYTHONPATH=/usr/lib/python2.7/dist-packages to the /etc/ld.so.conf file.
Sorry if this question is too basic, I am not too experienced on linux.

Best Regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]