[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] problem building uhd + gnuradio 3.5.3

From: anay tuljapurkar
Subject: [Discuss-gnuradio] problem building uhd + gnuradio 3.5.3
Date: Thu, 3 May 2012 19:04:56 -0400

Hey ,
     I am trying to install gnuradio version 3.5.3 with uhd for digital image processing purposes .
System Specs :
 ---> Ubuntu 10.10 Maverick - 64 bit machine. Hence i do the following.
Step 1) I build and install uhd first and so libuhd.so , libuhd.so.003.004 and libuhd.so.003 already do exist in the default usr/local/lib path .
step 2) Then i try to build gnuradio from source and i run ./configure --enable-gr-uhd which runs fine.
step 3) I run make which also seems to run fine but the error comes in when i try to run "make check", i get the following error message :

make[4]: Leaving directory `/home/anay/gnuradio/gr-uhd/doc'
Making check in swig
make[4]: Entering directory `/home/anay/gnuradio/gr-uhd/swig'
make  check-am
make[5]: Entering directory `/home/anay/gnuradio/gr-uhd/swig'
make  check-TESTS
make[6]: Entering directory `/home/anay/gnuradio/gr-uhd/swig'
Traceback (most recent call last):
  File "./qa_uhd.py", line 24, in <module>
    import uhd_swig
  File "/home/anay/gnuradio/gr-uhd/swig/uhd_swig.py", line 24, in <module>
    _uhd_swig = swig_import_helper()
  File "/home/anay/gnuradio/gr-uhd/swig/uhd_swig.py", line 16, in swig_import_helper
    import _uhd_swig
ImportError: libuhd.so.003: cannot open shared object file: No such file or directory

I wanted to plug in /usr/local/lib/ in ld.so.conf but it was already there. I have run it several times now and i cant seem to find a resolution to this .

I would be greatful if somebody were to help me out in this regard.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]