[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Blocks missing from GRC after pre-cog installatio

From: Josh Blum
Subject: Re: [Discuss-gnuradio] Blocks missing from GRC after pre-cog installation
Date: Mon, 22 Oct 2012 18:38:17 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20121011 Thunderbird/16.0.1

Oh noes, it looks like the pre-cog is overwriting the gnuradio-cores'
block_tree.xml. This should probably be renamed to pre_cog_block_tree.xml


On 10/22/2012 01:52 PM, Sakib Chowdhury wrote:
> Hi,
> I cannot figure out the source of the problem. I don't have multiple
> installations of gnuradio. While I'm installing gnuradio and grextras
> (either by the installation script from gnuradio.org website or by
> manually), I run git clone commands in ~/Downloads directory. Thus I have
> gnuradio and grextras folders in ~/Downloads folder. So, in the usual way I
> proceed to install, and they are properly installed in /usr/local/ . I run
> GRC and get all the blocks. I attached the screenshot. Then I run git clone
> command for pre-cog in ~/Downloads folder, so I have a pre-cog folder in
> ~/Downloads. I then proceed to install it in usual manner (mkdir build,
> cmake, make etc.) and it is properly installed. Then if I run GRC, blocks
> are missing, those that start with gr_*.xml. I have attached the screenshot
> too.
> Is there any other specific installation instructions?
> Thanks.
> On Thu, Oct 18, 2012 at 9:44 PM, Josh Blum <address@hidden> wrote:
>> On 10/18/2012 11:07 AM, Sakib Chowdhury wrote:
>>> Hi,
>>> Unfortunately reinstalling didn't solve the problem. I tried twice
>> already.
>>> What I did is first I removed all relevant gnuradio and uhd files and
>>> folders from /usr/* folders and installed gnuradio, uhd, grextras using
>> the
>>> script linked on gnuradio.org website:
>> Would you perhaps have multiple installs of gnuradio both in /usr and
>> /usr/local? That could be one issue
>> Also, while its ok to put gnuradio in /usr and grextras and pre-cog into
>> /usr/local. You will need to set the GRC_BLOCKS_PATH environment
>> variable to have entries for both block paths. The paths would be
>> your_install_prefix/share/gnuradio/grc/blocks
>> -josh
>>> http://www.sbrac.org/files/build-gnuradio . I opened GRC and found some
>>> newer blocks (obviously because of some updates to the source) along with
>>> my previously missing blocks. So, everything is fine. Then I installed
>>> pre-cog using the set of commands at the end of the page:
>>> https://github.com/buoyboy/pre-cog/wiki/Installation . After that I
>> opened
>>> GRC and blocks that start with gr_*.xml are gone.
>>> Please let me know if I'm doing something wrong with the installation.
>>> Isn't pre-cog supposed to be installed in this way? Or if pre-cog is
>>> required, I have to install gnuradio in some other way apart from using
>>> that script?
>>> Thanks.
>>> On Wed, Oct 17, 2012 at 5:32 PM, Johnathan Corgan
>>> <address@hidden>wrote:
>>>> On Wed, Oct 17, 2012 at 2:30 PM, Sakib Chowdhury <
>> address@hidden>wrote:
>>>>> I noticed that actually all block files (xml) are still there
>>>>> in /usr/local/share/gnuradio/grc/blocks/ . What GRC is not displaying
>> are
>>>>> the blocks whose names start with gr_*.xml . I'll try to reinstall.
>>>> This was a recently fixed bug on GNU Radio master branch, related to the
>>>> gr-blocks work Josh mentioned.
>>>> Johnathan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]