[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Changing the installation directory for GR

From: Uher, Jason J.
Subject: Re: [Discuss-gnuradio] Changing the installation directory for GR
Date: Tue, 6 Nov 2012 10:50:48 -0500


It did fail 3 times in a row (that was last week).  I tried it again after your 
suggestion and it worked great, I guess I should have been more optimistic this 

Everything is installed and the grc examples working, let me know if you need 
any debug information.

Thanks again!

-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Tom Rondeau
Sent: Tuesday, November 06, 2012 10:20
To: Uher, Jason J.
Cc: address@hidden
Subject: Re: [Discuss-gnuradio] Changing the installation directory for GR

On Tue, Nov 6, 2012 at 8:30 AM, Uher, Jason J. <address@hidden> wrote:
> Hi all,
> I have been using gnuradio on Ubuntu 12.04.1 LTS that I installed via the 
> 'build gnuradio' script and it has been going well.  I use it for a number of 
> projects and wanted to have a separate copy to change some of the code so I 
> downloaded the latest tarball, extracted it to a directory called 'working 
> copy' and did:
> cd working_copy/gnuradio-3.6.2/
> mkdir build && cd build
> make -DCMAKE_INSTALL_PREFIX:PATH=/home/jason/working_copy/gr
> This is (relatively) the same process I've used in the past when creating 
> working copies of gnuradio before cmake.
> The build went through without any warnings that seemed important, but 
> after 'make test' I get
>         Start   1: qa_volk_test_all
>   1/143 Test   #1: qa_volk_test_all .................   Passed    0.45 sec
>         Start   2: gruel-test
>   2/143 Test   #2: gruel-test .......................   Passed    0.86 sec
>         Start   3: qa_pmt
>   3/143 Test   #3: qa_pmt ...........................   Passed    0.03 sec
>         Start   4: gr-core-reed-solomon-test
>   4/143 Test   #4: gr-core-reed-solomon-test ........   Passed    0.02 sec
>         Start   5: gr-core-test-all
> Then that's it, it hangs.  So my question is: what next? I didn't see an 
> obvious way to add a verbose option to know what's going on.
> Thanks,
> Jason

Well, we've been trying to hide that problem, and so far, you're the first 
person to complain. That's actually been happening for a while, and we're 
really not sure what's going on. We've narrowed down /where/ it's happening but 
not /why/. I doubt it has anything to do with setting your own install 

Just rerun 'make test'. The lock happens randomly, but usually not multiple 
times in a row. We've also never seen this lock happen in any running 
applications. If it's happening to you every time, please let me know.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]