[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] WX Gui Widget Error

From: B Hun
Subject: Re: [Discuss-gnuradio] WX Gui Widget Error
Date: Fri, 1 Mar 2013 13:42:01 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

Mihai Chermaneanu <chrmihai <at> gmail.com> writes:

....(*args, **kwargs)ValueError: in method 'BookCtrlBase_SetSelection', 
expected argument 2 of type 'size_t'

I get the same error.  I just installed gnuradio for windows as per the 
instructions on the ettus website 

When I run the cvsd_sweep.grc example I get the same error:
...    return _controls_.BookCtrlBase_SetSelection(*args, **kwargs)
ValueError: in method 'BookCtrlBase_SetSelection', expected argument 2 of 
type 'size_t'.  I hear the sweet tone but all the plots a re messed up and do 
not display any data.

I uninstalled and reinstalled exverything but still get the same error.  I 
even tried going back to versions of each item, one at a time, that a coworker 
had working last year but I still get the same error.

I also ran the dial_tone.grc example and I hear the tone and the gui seems to 
work but I get this error:

s\gnuradio\lib\site-packages\gnuradio\grc\gui\Dialogs.py:36: GtkWarning: 
t_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
  self.insert = lambda line: text_buffer.insert(text_buffer.get_end_iter(), 
: Invalid argument
alid argument

Thanks for any help,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]