[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] WX Gui Widget Error

From: Josh Blum
Subject: Re: [Discuss-gnuradio] WX Gui Widget Error
Date: Fri, 01 Mar 2013 12:19:29 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130106 Thunderbird/17.0.2

On 03/01/2013 07:42 AM, B Hun wrote:
> Mihai Chermaneanu <chrmihai <at> gmail.com> writes:
> ....(*args, **kwargs)ValueError: in method 'BookCtrlBase_SetSelection', 
> expected argument 2 of type 'size_t'
> I get the same error.  I just installed gnuradio for windows as per the 
> instructions on the ettus website 
> (http://code.ettus.com/redmine/ettus/projects/uhd/wiki/GNURadio_Windows).
> When I run the cvsd_sweep.grc example I get the same error:
> ...    return _controls_.BookCtrlBase_SetSelection(*args, **kwargs)
> ValueError: in method 'BookCtrlBase_SetSelection', expected argument 2 of 
> type 'size_t'.  I hear the sweet tone but all the plots a re messed up and do 
> not display any data.
> I uninstalled and reinstalled exverything but still get the same error.  I 
> even tried going back to versions of each item, one at a time, that a 
> coworker 
> had working last year but I still get the same error.

So, gnuradio doesnt actually build against wx python, its just a runtime
dependency when using the WX GUI plotters and widgets. So, you shouldnt
have to reinstall everything, potentially, just wx python.

Now it looks like the error is within wx python guts. Which might mean
there is a bug in this version of wx python, or perhaps we are using one
of its widgets in an incompatible way.

For a quick fix. I recommend trying a older version of the wx python
installer and see if any errors become fixed. But we should really find
out what widget is calling into this BookCtrlBase and double check that
API that we are using it right.

> I also ran the dial_tone.grc example and I hear the tone and the gui seems to 
> work but I get this error:
> ...\AppData\Roaming\.gnuradio\prefs\gr_vmcircbuf_default_factoryC:\app
> s\gnuradio\lib\site-packages\gnuradio\grc\gui\Dialogs.py:36: GtkWarning: 
> gtk_tex
> t_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
>   self.insert = lambda line: text_buffer.insert(text_buffer.get_end_iter(), 
> line
> )
> : Invalid argument
> ÉÖI?°êI?\bhehn\AppData\Roaming\.gnuradio\prefs\gr_vmcircbuf_default_factory: 
> Inv
> alid argument

I think these are warnings that can be ignored.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]