[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] build-gnuradio on Scientific Linux 6.3

From: mleech
Subject: Re: [Discuss-gnuradio] build-gnuradio on Scientific Linux 6.3
Date: Wed, 20 Mar 2013 14:17:45 -0400
User-agent: Roundcube Webmail/0.7.2

On 20 Mar 2013 14:03, Jonathan Fox wrote:

On Wed, Mar 20, 2013 at 1:51 PM, <address@hidden> wrote:

On 20 Mar 2013 12:47, Jonathan Fox wrote:

I am having a problem with the build-gnuradio script on Scientific Linux 6.3 (x86_64). I added myself to sudoers and tried running the script but I usually get this this output:

Starting all functions at: Wed Mar 20 12:31:31 EDT 2013
SUDO privileges are required
Do you have SUDO privileges?y
Continuing with script
./build-gnuradio.sh: line 1249: tmp18685: Permission denied
cat: tmp18685: No such file or directory
Installing prequisites...Checking for library libusb ...Found library libusb
Checking for library libboost ...Found library libboost
Checking for library libcppunit ...Found library libcppunit
Checking for library libguile ...Found library libguile
Checking for library libfftw ...Found library libfftw
Checking for library libgsl ...Found library libgsl
touch: cannot touch `touch18685': Permission denied
Fetching Gnu Radio via GIT...Could not find gnuradio/gnuradio-core after GIT checkout
GIT checkout of Gnu Radio failed!

I looked at the shell script's line 1249 and I can see that it wants to access my sudoers file. Am I suppose to change sudoers' default permissions? This problem has been frustrating me for a while especially considering I have successfully installed GNU Radio on RHEL before. I appreciate any help on this matter.


Jonathan Fox

It's never been tested on Scientific Linux, and the RHEL support is only very lightly tested--by exactly one person, as far as I know.

Are you running this in a directory that you wouldn't have write-access to if root?  Like an NFS mount maybe?



Discuss-gnuradio mailing list

I tried running it in /usr/local and /usr/local/src. Right now I am trying in /home/$USER/workspace and I think that could of done the trick. I suppose when it is done or if it finishes, I can move the source directories to /usr/local/src.

This problem seems odd because I can run this script in /usr/local on Ubuntu boxes but not in a RHEL clone.

Thanks for the response.


It's intended to run in an ordinary user directory -- only only uses "sudo" for the final "make install" and post-install stuff.  Downloading and compiling code isn't something that requires root privilege, so those bits just run as an ordinary user.

Possibly Ubuntu sets up /usr/local to be regular-user writeable, but that would be a horrible security flaw.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]