[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gr_fir_fff: using 3DNow! core dump

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] gr_fir_fff: using 3DNow! core dump
Date: Wed, 20 Mar 2013 19:50:56 -0400

On Wed, Mar 20, 2013 at 10:58 AM, Sid Boyce <address@hidden> wrote:
> On 20/03/13 13:08, Tom Rondeau wrote:
>> On Tue, Mar 19, 2013 at 9:20 PM, Sid Boyce <address@hidden> wrote:
>>> I have a program that uses gnuradio to work with a HiQSDR.
>>> The first time I fired up qsdr it worked.
>>> Closing it down and re-opening later I got the error. A reboot of the
>>> system
>>> didn't solve it.
>>> $ qsdr
>>> starting server
>>> Using Volk machine: sse4_a_64
>>>>>> gr_fir_fff: using 3DNow!
>>> terminate called after throwing an instance of 'std::runtime_error'
>>>    what():  unpaired unlock() call
>>> Aborted (core dumped)
>>> 73 ... Sid.
>> Sid,
>> What version of GNU Radio are you using for this? You should try to
>> pull in the filter from the filter module instead of from gr:
>> from gnuradio import filter
>> fir = filter.fir_filter_ccf(decim, taps)
>> ....
>> Also, what is your processor?
>> Tom
> This is the output from the openSUSE boxes and the CPU flags which don't
> include sse4_a.
> Later I'll try rebuilding gnuradio with "-msse3" to see if that helps.
> # qsdr
> starting server
> gri_fftw: can't import wisdom from /root/.gr_fftw_wisdom
> Using Volk machine: avx_64_mmx_orc
>>>> gr_fir_fff: using SSE
> connection from  ""
> TCP: conneced
>>>> gr_fir_ccc: using SSE
>>>> gr_fir_ccf: using SSE
>>>> gr_fir_fcc: gr_fir_fcc: using SSE
> flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
> cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
> pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid
> aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave
> avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse
> 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext
> perfctr_core perfctr_nb arat cpb hw_pstate npt lbrv svm_lock nrip_save
> tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
> 73 ... Sid.
> --
> Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
> Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
> Senior Staff Specialist, Cricket Coach
> Microsoft Windows Free Zone - Linux used for all Computing Tasks


Have you tried using the filters out of the filter module, yet? Those
filters use VOLK for SIMD instead of the hand-crafted stuff that in
the gr filters. That might help. Besides which, we're removing those
filters, so moving to the new filter module will keep you more
compatible as we go forward.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]