[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Build failures on Ubuntu 12.04 32-bit

From: Tommy Tracy II
Subject: Re: [Discuss-gnuradio] Build failures on Ubuntu 12.04 32-bit
Date: Fri, 29 Mar 2013 14:23:07 -0400

I just tried the build on my 32-bit Ubuntu 10.04 VM and got the following error:

[ 70%] Building CXX object gr-digital/lib/CMakeFiles/gnuradio-digital.dir/packet_header_default.cc.o
/home/tjt7a/src/gnuradio/gr-digital/lib/packet_header_default.cc: In member function ‘bool gr::digital::packet_header_default::header_formatter(long int, unsigned char*, const std::vector<gr_tag_t, std::allocator<gr_tag_t> >&)’:
/home/tjt7a/src/gnuradio/gr-digital/lib/packet_header_default.cc:71: error: ‘memset’ was not declared in this scope
make[2]: *** [gr-digital/lib/CMakeFiles/gnuradio-digital.dir/packet_header_default.cc.o] Error 1
make[1]: *** [gr-digital/lib/CMakeFiles/gnuradio-digital.dir/all] Error 2
make: *** [all] Error 2

I added #include <string.h> to the top of the file, and it seems to have completed the build for that file.

Tommy James Tracy II
Ph.D Student
High Performance Low Power Lab
University of Virginia
Phone: 913-775-2241

On Mar 29, 2013, at 1:53 PM, Tom Rondeau <address@hidden> wrote:

Ralph, Marcus, et al.,

I've pushed a fix just now for the 32-bit OS problem. See issue #529
for the problem/solution.


On Thu, Mar 28, 2013 at 5:02 PM, Tom Rondeau <address@hidden> wrote:
On Thu, Mar 28, 2013 at 3:56 PM, Marcus D. Leech <address@hidden> wrote:
Just tried to do a build now, from latest GIT.

Attached is the make.log file.

This Ubuntu 12.04 system is up-to-date as of today.

Boost is 1.48
GCC is 4.6.3
Swig is 2.0.4

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium

Working off-list with Ralph, we found the problem. Seems specific to
32-bit machines, though. I have to figure out what the right fix is,
but I'll get to that soon.


Discuss-gnuradio mailing list

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]