[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Something wrong when I tried to create a out-of-tree

From: PanTianqi
Subject: [Discuss-gnuradio] Something wrong when I tried to create a out-of-tree module
Date: Tue, 13 Aug 2013 14:54:50 +0000 (GMT)

Hello all, 

     My gnuradio worked fine before, but recently when I use the command:

                                     gr_modtool newmod howto

to create a out-of-tree module, error occurs and it says,

  Traceback (most recent call last):
  File "/usr/local/bin/gr_modtool", line 26, in <module>
    from gnuradio.modtool import *
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/modtool/__init__.py", line 30, in <module>
    from modtool_newmod import ModToolNewModule
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/modtool/modtool_newmod.py", line 27, in <module>
    from gnuradio import gr
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/gr/__init__.py", line 41, in <module>
    from runtime_swig import *
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/gr/runtime_swig.py", line 26, in <module>
    _runtime_swig = swig_import_helper()
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/gr/runtime_swig.py", line 22, in swig_import_helper
    _mod = imp.load_module('_runtime_swig', fp, pathname, description)
ImportError: dynamic module does not define init function (init_runtime_swig)

     Same thing happens when I input "from gnuradio import gr" in python code. It never happens before. Moreover, when I reinstall 

gnuradio, a module called gr-iqbal cannot be built........

      Does anybody have met such problem or have tackled it? Appreciate your help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]