[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Make tests failed when Building for version 3.7.1

From: Damon
Subject: Re: [Discuss-gnuradio] Make tests failed when Building for version 3.7.1git
Date: Tue, 20 Aug 2013 21:05:27 +0800
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130803 Thunderbird/17.0.8

On Mon, Aug 19, 2013 at 8:29 AM, Damon <address@hidden> wrote:
Hi all,

I tried installing GNUradio v3.7.1git. The build completed, but several of
the build tests fail.

The OS is Ubuntu 12.04 32bit, with kernel version Linux
3.2.0-51-generic-pae. CPU is Intel® Core™ i7-3770 CPU @ 3.40GHz × 8 .

The prerequisites were built by :
apt-get install libfontconfig1-dev libxrender-dev libpulse-dev swig g++ \
automake autoconf libtool python-dev libfftw3-dev \
libcppunit-dev libboost1.48-all-dev libusb-dev libusb-1.0-0-dev fort77 \
libsdl1.2-dev python-wxgtk2.8 git-core \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools libusb-1.0-0-dev \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4 \
cmake git-core wget libxi-dev python-docutils gtk2-engines-pixbuf r-base-dev
python-tk \
liborc-0.4-0 liborc-0.4-dev libasound2-dev python-gtk2

then I ran cmake, make and make test.
The following tests FAILED:
       1 - qa_volk_test_all (Failed)
      85 - qa_freq_xlating_fir_filter (Failed)
      93 - qa_fir_filter (Failed)
     167 - qa_codec2_vocoder (Failed)
So  I ran:
ctest --output-on-failure -O ctest_log_file
Attached please find the log file.

How to fix it?

Best regards,

Thanks for the detailed report. Can you try uninstalling ORC and
rebuilding without it? It looks like those errors might be related to
differences in precision/rounding with ORC.

And ignore the codec2 problem, unless you specifically want to use
codec2. It's a known problem, but we don't have a fix for it, yet.

Hi Tom,

There are 2 orc installed: liborc-0.4-0 and liborc-0.4-dev.
I uninstalled liborc-0.4-dev, rebuilt gnuradio. The volk passed
test. But several tests failed:
     85 - qa_freq_xlating_fir_filter (Failed)
     93 - qa_fir_filter (Failed)
    167 - qa_codec2_vocoder (Failed)
Attached please find the log file: ctest_log_file.

In my another computer, I uninstalled both liborc-0.4-0 and liborc-0.4-dev.
Then I rebuilt uhd and gnuradio v3.7.0. Three tests mentioned above failed too.
Attached please find the log file: ctest_log_file2.

Any suggestions?


Attachment: ctest_log_file
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]