[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] WavFile_Sink Issues: slowed down sound - multipli

From: Luke Berndt
Subject: Re: [Discuss-gnuradio] WavFile_Sink Issues: slowed down sound - multiplied playing time
Date: Fri, 30 Aug 2013 20:23:46 -0400

Thanks Andrew! - I am actually able to play the sound fine through sound card using the audio_sink block. It was is when I try recording it to a .wav file using the wavfile_sink block that the sounds becomes distorted. I have tired using a resampler and also tried a variety of different sample rate on the wavfile_sink, but none of them sounded normal.

gr-dsd is a vocoder block and its decoding is sort of bursty. Sometimes it seems to only take 4 input packets to equal 1 output, others it is 8 or 11. Any wise, I am wondering I am getting some form of under run. I am not getting 'aUaU' on the screen. Sometimes the sound from audio sink initially sound garbled but then becomes normal, so I wonder if it is an issue of needing to buffer up. I have tried adding in a Forecast, but it didn't help.

Any other tips would be great!

 - Luke

On Aug 30, 2013, at 5:03 PM, Andrew Davis <address@hidden> wrote:

I'm not sure exactly what you are doing, but some sound cards don't support very many rates, windows always re-samples to some rate supported by the card, in linux you get more direct access to sound hardware and so you can send it rates it may not like, you could add a re-sampler/sound manager like pulse to handle all this for you, worked for me with similar issues.


On Fri, Aug 30, 2013 at 10:53 AM, Luke Berndt <address@hidden> wrote:
So I clearly have a sample rate mis-match. I am trying to record the audio from the gr-dsd block. I don't seem to have an issue doing it using GRC. However when I try doing using C++ the audio sounds extra slow and choppy and the playing time is much longer than I was actually recording for. I gr-dsd block is supposed to output audio at 8khz. I have the wavfile_sink set at 8000 for the samples per sec parameter. I use the same setting in GRC and it works fine. I have also tried passing this through a resampler to get the audio rate up to 44.1khz and I still have the same problem. If I use an audio_sink set to a sample rate of 44100 instead, I am able to listen to the audio with no problem.

Any idea what is going on or what I can try?


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]