[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] setup of usrp N100/N200

From: Sandhya G
Subject: Re: [Discuss-gnuradio] setup of usrp N100/N200
Date: Mon, 21 Oct 2013 16:40:18 +0530

Yes sir .your right i thought my pc is ethernet capable.I brushed the spec of pc hardware it just supports maximum 100mbps .so i'm installing gnuradio on pandaboard which supports gigabyte.

Thanks and regards

On Mon, Oct 21, 2013 at 11:58 AM, Activecat <address@hidden> wrote:
Chances are your pc hardware is actually not GE capable.

On Mon, Oct 21, 2013 at 2:23 PM, Sandhya G <address@hidden> wrote:
ok sir then i'l try to debug the problem in my os now


On Mon, Oct 21, 2013 at 11:49 AM, Activecat <address@hidden> wrote:
As I mentioned in previous email (below), the first thing you need to do now is to bring up the physical layer of the Ethernet connection.
If the GE port LED is not ON, no point to proceed without this being solved first.

If you insist that your hardware support 1000Mbps GE, then make the Linux recognise this first before troubleshooting at the gnuradio level.

Now you should troubleshoot your Linux, not gnuradio, if you confirmed that your hardware is really GE capable.

---------- Forwarded message ----------
From: Activecat <address@hidden>
Date: Mon, Oct 21, 2013 at 1:09 PM
Subject: Re: [Discuss-gnuradio] setup of usrp N100/N200
To: Sandhya G <address@hidden>
Cc: address@hidden

You shall troubleshoot in the following steps:

1).  Bring up the physical ethernet connection between your PC and the USRP. Upon successful you will see the LED turns on at the USRP GE port.

2). Set your PC IP address to the same subnet but don't crash with the USRP's ip address.
     If this step is successful then you will be able to ping the USRP.

3).  Issue command "uhd_find_devices" and you will see the USRP being discovered.

Then you could proceed with "uhd_usrp_probe" to see more details.

On Mon, Oct 21, 2013 at 2:02 PM, Sandhya G <address@hidden> wrote:
OS is linux. my pc is 2010 model,has
  • 3rd Generation Intel® Core™ i5-3317U
  • 64-bit.

And when i give the command sudo ethtool eth1 i'am getting the speed has 10Mb/s

Settings for eth1:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: no

And ya GE port led is not ON



On Mon, Oct 21, 2013 at 11:04 AM, Activecat <address@hidden> wrote:
What operating system are you running, is it Linux or Microsoft Windows?

On Mon, Oct 21, 2013 at 1:25 PM, Sandhya G <address@hidden> wrote:
 i'm seeing only LED's D and F are on, because host pc is not at all detecting the hardware and i'm unable to run any operation.In my first i mentioned the errors what i'am getting when i run the flowgraph. 
Even i'am clueless how my device is only showing up 10/100Mbps when i connect the hardware and even i tried with other pc but i'm facing the same problem.

Thanks and regards

On Mon, Oct 21, 2013 at 10:42 AM, Activecat <address@hidden> wrote:
What operating are you running? How do you get the "10/100Mbps" ?  Do you see the LED turns on at the USRP GE port?

On Mon, Oct 21, 2013 at 1:09 PM, Sandhya G <address@hidden> wrote:
Sir my pc is capable of supporting 1000Mbps but when i connect the hardware and check the speed of the port it will be showing 10/100Mbps.
What might the issue?and can i boost the pc speed

Thanks and regards

On Mon, Oct 21, 2013 at 10:30 AM, Sandhya G <address@hidden> wrote:
ya its a new one and sir y i'am i getting unknown key format even though i give addr= and the problem i'm facing is its showing me an error has cannot find as a single device.I have no clue the reason for that

Thanks and regards

On Mon, Oct 21, 2013 at 10:24 AM, Activecat <address@hidden> wrote:
If that is a new USRP from factory then you don't need to update the firmware.

On Mon, Oct 21, 2013 at 12:51 PM, Sandhya G <address@hidden> wrote:
Thanks for the reply.
Well is that only problem so that i'm unable to communicate and should i need to update the firmware?

Thanks and regards

On Mon, Oct 21, 2013 at 10:19 AM, Activecat <address@hidden> wrote:
Your pc must have 1000Mbps port. The 10/100Mbps won't work.
An alternative is to connect a 10/100/1000 LAN switch between your pc and the USRP.


On Mon, Oct 21, 2013 at 12:37 PM, Sandhya G <address@hidden> wrote:

HI all,

I have followed as per the instructions given in the webpage for set up of the Usrp N200/N210 but still i am unable to communicate between the  hardware and host pc


                1.I have set the static ip of the host pc to eth0

2.Whenever i give the device address=addr= and run the grc i am getting the error has “unknown key format” 

3.Whenever i ping or use the command  uhb_find_device  i am getting warning as “NO DEVICE FOUND

4. Is that a must i have to upload the fpga and firmware images when using the device for the first time.

5.Sometimes i am getting an error like” unable to find as single device”.

6.The host pc is supporting only 10/100MBPS .Is that the only problem so that i am unable to communicate with the hardware.


Can anybody help me on this issue.Awaiting for your valuable reply

Thanks in advance 


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]