discuss-gnuradio
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] First proper build - missing blocks


From: Martin Braun (CEL)
Subject: Re: [Discuss-gnuradio] First proper build - missing blocks
Date: Mon, 28 Oct 2013 14:55:43 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

On Mon, Oct 28, 2013 at 12:29:31PM -0000, address@hidden wrote:
> Sorry but this is a very newbie question. I tried to get GR up and running
> many years ago when Fedora 8 was new! I then tried a couple of times to get
> it going on windows - I got some blocks up but could not move or connect
> then. I have now just installed Ubuntu 13.10 on an old laptop to have a
> proper go at getting GR up and running as I now have some time to try and
> play properly.
> 
> I went with the simplest looking way of doing GR3.7.1 with
> $ sudo apt-get install gnuradio
> but ended up with 205 warnings and a load of errors.

You got errors when running apt-get install gnuradio? Can you please
pastebin them somewhere?

In general, you can and should use apt-get install if the version you
get is "new enough" for your taste.

> I tried this a couple of times with same result.
> 
> I then tried to remove as much of this as I could and went down this road
> $ git clone http://git.gnuradio.org/git/gnuradio.git
> $ ./build-gnuradio

FYI: build_gnuradio does the cloning for you.

> And this seemed to work OK. No warnings, no errors.
> 
> Some time later I managed to get gnuradio-companion (can I still call it
> grc?) up and running and tried to get the Dial Tone example built.

You can't call it grc on the command line (there was a package conflict
a while back).

> First thing - no Signal Source block. The only source blocks I have in Audio
> is Audio Source and Wav File Source, no Signal Source.
> 
> I then tried to load up rtl2832-cfile.grc and ended with multiple
> >>>> Error: Block key "gr_file_source" not found in Platform - grc ...
> Other blocks not found included gr_uchar_to_float, gr_add_const_vxx,
> gr_multiply_const_vxx, gr_float_to_complex stc.

It seems like you're trying to import a really old flow graph. All of
these blocks have been moved to a new sub-component (in this case,
gr-blocks).

When you start GRC, you can find all of these blocks in the sidebar.
This way, you should be able to reconstruct your flow graph in no time.

MB


-- 
Karlsruhe Institute of Technology (KIT)
Communications Engineering Lab (CEL)

Dipl.-Ing. Martin Braun
Research Associate

Kaiserstra├če 12
Building 05.01
76131 Karlsruhe

Phone: +49 721 608-43790
Fax: +49 721 608-46071
www.cel.kit.edu

KIT -- University of the State of Baden-W├╝rttemberg and
National Laboratory of the Helmholtz Association

Attachment: pgpFleUkIqFBa.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]