[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] First proper build - missing blocks

From: Marcus Leech
Subject: Re: [Discuss-gnuradio] First proper build - missing blocks
Date: Mon, 28 Oct 2013 14:22:49 +0000 (UTC)

The blocks in GRC have moved around quite a bit in the last year or so.

A simple signal source can now be found under "Waveform Generators", and if you move your mouse into the panel on the right, with all the blocks
   categories, you can use CTRL-F, which will pop up a little text-entry box and allow you to search for blocks.
It's likely that the .grc example you're trying to use was done for GR3.6, and there has been a major API overhaul between 3.6 and 3.7.
  By default, build-gnuradio fetches and builds GR3.7, but you can have it fetch/build 3.6 using the "-o" flag.
on Oct 28, 2013, address@hidden <address@hidden> wrote:
Sorry but this is a very newbie question. I tried to get GR up and running
many years ago when Fedora 8 was new! I then tried a couple of times to get
it going on windows - I got some blocks up but could not move or connect
then. I have now just installed Ubuntu 13.10 on an old laptop to have a
proper go at getting GR up and running as I now have some time to try and
play properly.

I went with the simplest looking way of doing GR3.7.1 with
$ sudo apt-get install gnuradio
but ended up with 205 warnings and a load of errors.

I tried this a couple of times with same result.

I then tried to remove as much of this as I could and went down this road
$ git clone http://git.gnuradio.org/git/gnuradio.git
$ ./build-gnuradio
And this seemed to work OK. No warnings, no errors.

Some time later I managed to get gnuradio-companion (can I still call it
grc?) up and running and tried to get the Dial Tone example built.

First thing - no Signal Source block. The only source blocks I have in Audio
is Audio Source and Wav File Source, no Signal Source.

I then tried to load up rtl2832-cfile.grc and ended with multiple
>>>> Error: Block key "gr_file_source" not found in Platform - grc ...
Other blocks not found included gr_uchar_to_float, gr_add_const_vxx,
gr_multiply_const_vxx, gr_float_to_complex stc.

These all seem like some of the really basic stuff. I have done quite a few
hours of googling with "not found in Platform" etc but have not been able to
get any further.

I realise this is not quite up the level of most posts here but I hope
someone may have seen this before and knows exactly what the problem is.

Thanks, Andy.

Discuss-gnuradio mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]