[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Setup process for B210 with GNURadio -- device detect

From: Steve
Subject: [Discuss-gnuradio] Setup process for B210 with GNURadio -- device detection issue
Date: Tue, 12 Aug 2014 17:46:59 +0000

Greetings to the group

This is another connection issue for the B210, however I think it somewhat unique having tried the solutions provided for other users, although I am a newbie so it could be something very obvious or I misunderstood previous instructions.  I am using --

Ubuntu 14.04 (VM VirtualBox)
GNURadio 3.7.3
UHD 003.007.001
(which I understand are the latest versions, from the repository and have tried both stable and unstable versions).

>From a clean snapshot (without any GNU radio, python or UHD) and following advice from the forums I performed the following installation sequence --

sudo apt-get install python python-wxgtk2.8 pyqt4-dev-tools python-qwt5-qt4 python-numpy libboost-all-dev libusb-1.0.0-dev
sudo bash -c 'echo "deb http://files.ettus.com/binaries/uhd_stable/repo/uhd/ubuntu/`lsb_release -cs` `lsb_release -cs` main" > /etc/apt/sources.list.d/ettus.list'
sudo bash -c 'echo "deb http://files.ettus.com/binaries/uhd_stable/repo/gnuradio/ubuntu/`lsb_release -cs` `lsb_release -cs` main" >> /etc/apt/sources.list.d/ettus.list'
sudo apt-get update
sudo apt-get install -t `lsb_release -cs` uhd gnuradio
sudo apt-get install python-cheetah

I get the report in gnuradio that the device cannot be found (I have tried running both as sudo or as a normal user in case of permissions -- a bit new to linux).  When setup with just a UHD source and a FFT sink GNURadio returns:
RuntimeError: LookupError: KeyError: No devices found for ----->
Empty Device Address

Seeing the solution provided in this mailing list I have tried to modify udev rules as follows:
sudo gedit /lib/udev/rules.d/40-uhd-host.rules
SUBSYSTEMS=="usb", ATTRS{idVendor}=="2500", ATTRS{idProduct}=="0020", GROUP:="usrp", MODE:="0660"
I have also tried with the stable equivalent, again from a fresh snapshot.

When I run lsusb I can see the device 2500:0020 (sometimes) although it frequently disappears.
Bus 001 Device 032: ID 2500:0020 
Bus 001 Device 007: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 0a5c:21d7 Broadcom Corp. BCM43142 Bluetooth 4.0
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Using sudo uhd_find_devices I get the following, which appears like it has identified something as it tries to load image (unlike it not connected) but then fails:
linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.001-20-unstable
-- Loading firmware image: /usr/share/uhd/images/usrp_b200_fw.hex... done
No UHD Devices Found

I am not sure why it is trying to load b200 when it is a b210 (4 ch)?  I read that using uhd_usrp_probe with an address might work but unsure how to do this without an IP address.

I have tried both powering through the USB only or providing 6V in case it is a supply issue, noting in the second case a change in current draw once I start trying to interact from 40 mA to 120 mA.

Many thanks for any pointers --


reply via email to

[Prev in Thread] Current Thread [Next in Thread]