[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] problem in boost in Windows 8 OS

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] problem in boost in Windows 8 OS
Date: Wed, 20 Aug 2014 08:32:50 -0500

On Fri, Aug 15, 2014 at 1:40 PM, Bogale, Tadilo Endeshaw <address@hidden> wrote:
Dear all

I have tried to install the out of tree module "howto" (the code is attached) in the Gnuradio. However, it seems that "boost" software is not working correctly (I DO NOT KNOW WHY?).


I have used the following command to install the module

mkdir build
cd build/
cmake ../      (I got an error in this command)

It says boost not found

"boost required to compile howto"

To fix this problem

I have modified the cmake command exactly as in


To make it clear, I have used the following commands

1. unpack boost_1_55_0.zip file in "C:\boost" directory
2. cd c:\boost\boost_1_55_0
3. bootstrap
4. .\b2 --prefix=\opt\boost_1_55_0 --with-thread --with-date_time --with-program_options --with-filesystem --with-system --layout=versioned threading=multi variant=release install

I think, this installs boost correctly

Once boost is installed, I have used the following commands to install the "howto" module

mkdir build
cd build/
cmake -DBOOST_ROOT=c:\boost\boost_1_55_0\opt\boost_1_55_0 -DBoost_INCLUDE_DIR=c:\boost\boost_1_55_0\opt\boost_1_55_0\include\boost-1_55\ -DBoost_LIBRARY_DIRS=c:\boost\boost_1_55_0\opt\boost_1_55_0\lib  ../

With this command, I also get the same error (boost not found).

Note that I am using command line on "Windows 8 operating system".

Do you think that the problem arises because I am using windows 8 OS, or
Should I install GNURADIO, CMAKE and Boost in some specific orders and directories.

Any help is appreciated.



Unfortunately, you'll find very few Windows people here to help you. But what you wrote above looks like you're doing the right thing, or near enough at least. If you post the complete output of cmake, that might help us see better what's going wrong.

Also, you've verified that things like libboost_system.dll are installed in the c:\boost\boost_1_55_0\opt\boost_1_55_0\lib?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]