[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] CentOS pymbombs install

From: Marcus Müller
Subject: Re: [Discuss-gnuradio] CentOS pymbombs install
Date: Wed, 07 Jan 2015 15:11:07 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.3.0

Jep, GRC running beautifully, together with QtGUI (see screenshot ;) ). By the way, now I have to actually try getting wx to run on centOS. (sorry, Tim...)
@Rich: I just realize that you didn't want it to build from source; please ignore my ignorant question.

On 01/07/2015 03:05 PM, Tom Rondeau wrote:
On Wed, Jan 7, 2015 at 7:31 AM, Marcus Müller <address@hidden> wrote:
Hello Rich, Hello Tom,

I've been able to do an un-pybombed build of GR incl. gr-uhd and gr-qtgui on CentOS 7[1]; I can also confirm that getting wxPython on CentOS 7 was not worth proving it works (ie. it was hard, and I got tired).
However, having chosen to have the default software development tools at installation time, and after adding EPEL [2] (mainly because QWT is missing in the official repos), doing a
sudo yum install numpy python-devel fftw-devel alsa-lib-devel boost-devel swig PyQt4-devel qwt-devel cmake python-cheetah
I was able to get GNU Radio build in my VM. The things I did not try were enabling testing (pretty sure that would be easy), zeromq, video-sdl (not much sense in a VM, to be honest), doxygen and sphinx (not because it would have been complicated to install both tools -- I just wanted to save on build time...).

The problem here is that someone (um...) would have to go through all the recipes and make sure the rpm lines are correct for CentOS 7 -- and I guess, we might end up in a situation where the single "ok, this rpm satisfies this need" statement doesn't hold through for all distributions that have yum; so this might be a bit of work. However, pygobject's RPM "pygobject2-devel" can, at least for me, be installed from the base repos without a problem; Rich, why are you trying to build it from source?


[1] http://marcus.hostalia.de/Screenshot_centos7.0_2015-01-07_13:10:48.png
[2] sudo yum localinstall http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm


Yeah, I got just about as far as that, too. Were you able to get GRC running? I got hung up on the wxPython issue that I think I forgot to check that.


On 01/07/2015 12:46 AM, Tom Rondeau wrote:
On Tue, Jan 6, 2015 at 4:43 PM, Richard Bell <address@hidden> wrote:
Thanks, I did try 'sudo yum clean all'. I've tried a lot of things, this is the fifth or 6th time I've tried installing gnuradio on this CentOS laptop.

If I follow the link to the ftp site its looking for the tarball in, which is here:


There seems to be no more tarball with a 'patched' modifier at the end of it. Will gnuradio be ok if I install pygobject-2.27.91.tar.gz, or a newer version perhaps? I just don't know enough about these packages and the inner workings of gnuradio.



Is this CentOS 7? If so, you're probably not going to get very far. I've yet to figure out how to cleanly get GNU Radio to install on that OS. It works great on CentOS 5 and 6, but they've changed a lot with 7, specifically in removing (as far as I can tell) wxPython support.


On Tue, Jan 6, 2015 at 1:01 PM, Marcus D. Leech <address@hidden> wrote:
I've been running into difficulties using pybombs on my CentOS machine. I was told many users in the community use CentOS successfully so I'm looking to you for guidance. I am following the pybombs install instructions here:


The uhd install completes without any issue. Pybombs identifies missing dependencies, installs them all and then installs uhd. Great.

When I begin the gnuradio install, it identifies missing dependencies, begins installing them, but whenever it gets to pygobject, I run into the following issue:

--2015-01-06 12:24:07--  http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving ftp.gnome.org...,,, ...
Connecting to ftp.gnome.org||:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz [following]
--2015-01-06 12:24:07--  http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving gensho.acc.umu.se..., 2001:6b0:e:2018::176
Connecting to gensho.acc.umu.se||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-01-06 12:24:07 ERROR 404: Not Found.

This happened yesterday and it's happening today. Can someone help me through this please.


This really has nothing to do with PyBombs or Gnu Radio.

Your distributions Repo is pointing you at a mirror that doesn't have the file that it should have.  Not sure if there's a way on Centos to flush
  things so that it tries a different mirror.


sudo yum clean all

And try again?

Pybombs just uses your native package-management framework to fetch and install "stuff".  It doesn't know much about the internals of that, but
  relies on your systems package-management system to be "sane".  In this case, some part of it is "insane", and there's nothing that PyBombs
  can do about that.

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]