[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] pybombs, gnuradio, libprotobuf issues PLEASE HELP

From: ben Gee
Subject: Re: [Discuss-gnuradio] pybombs, gnuradio, libprotobuf issues PLEASE HELP ME
Date: Thu, 26 Mar 2015 11:01:15 -0400

thanks rich. I think at this point its some ghost-in-the-machine file or config that's outside the pybombs directory. That makes little sense because pybombs should be self-contained, therefore when i delete the pybombs and target directories it should not have any difference. That being said, it's just not working. 

i'm going to re-install ubuntu and follow the directions that Iluta sent  me. Her instructions seem to also have details on fixing the fosphor issues i was having which was what started this whole mess in the first place.


On Wed, Mar 25, 2015 at 4:38 PM, Richard Bell <address@hidden> wrote:
I think you might be referring to the config.dat file that was created after your first attempt at installing with pybombs? When you first clone pybombs, there is no config.dat, only a config.default. When you go through the install process, pybombs creates a config.dat that saves the choices you made. Now if you try and re-install with the same pybombs as before, all of your previous answers will be used during the setup.

Delete the config.dat file in the pybombs directory if you want to start from scratch.


On Wed, Mar 25, 2015 at 1:31 PM, ben Gee <address@hidden> wrote:
yes, i setup the environment variables. i noticed something strange though, in my initial (working) install, when i pulled the pybombs source using: 
git clone git://github.com/pybombs/pybombs and cd into pybombs
in my initial configuration i was able to set my prefix dir to /home/profile_name/pybombs , but now it forces me to use the prefix /home/profile_name/target or it says it can't install gnuradio in that location unless i fix my permissions. I'm not sure what's wrong with my permissions though, if anything. 

On Wed, Mar 25, 2015 at 3:01 PM, Richard Bell <address@hidden> wrote:
Did you run ./pybombs env and setup your environment variables?


On Wed, Mar 25, 2015 at 11:52 AM, ben Gee <address@hidden> wrote:
ok, so editing the .cc file worked now and i got it to stop throwing the compile error, but its still not working. 

gnuradio-companion still isn't installed correctly as i can't call it from the command line. when i run swig -version i get:

i have a second computer with a completely working gnuradio pybombs system that i originally installed alongside this one (which was working, until i reinstalled gnruadio and pybombs) so this is super frustrating that i can't duplicate it on a literally identical machine from the wiki instructions. i hate to perform brain surgery with a bazooka here, but i'm considering reinstalling ubuntu and starting over completely at this point. 

any thoughts?

On Wed, Mar 25, 2015 at 2:20 PM, ben Gee <address@hidden> wrote:
thanks ron, my swig version is now updated.
so, if i run ./pybombs install gnuradio and it reports the error with atsc_interleaver_impl.cc, i then go in and add "#include <stdio.h>", but now when i rerun ./pybombs install gnuradio, it still throws an error about the stdio commands not being included. is there a way to 'make clean' manually or something in pybombs?

On Tue, Mar 24, 2015 at 7:30 PM, Ron Economos <address@hidden> wrote:
I've submitted a pull request for the compile issue in gr-dtv.
However, it takes a little while for requests to get merged.

You're missing gnuradio-companion because your version of
SWIG is failing the version check. See line 982 in your first
pastebin. The minimum SWIG version required is 1.3.31.
You can see what version of SWIG you have with:

swig -version


On 03/24/2015 04:03 PM, ben Gee wrote:
> NEW ISSUE - no GRC??. I can't call it from the target, home or pybombs
> directory and there's no recipe for it. any thoughts?

GRC comes with gnuradio itself.

that's what i thought as it's always been that way.

If it's not there, something failed during the cmake/build step, but
without the full logs, can't really say anything.

yes, i agree about the build log. It would be a huge help if someone on the forum board could help me out,
as i have looked through most of the files in the installation and can't find a build log

i piped my terminal output of ./pybombs install gnuradio -v to this file:
the same compile error showed up on the terminal for gnuradio/gr-dtv/lib/atsc/atsc_interleaver_impl.cc cause no one's fixed the repo yet. I fixed that and re-ran ./pybombs install gnuradio which gave this output:

same issues as before. uhd is installed no problem, grc doesn't show up
hopefully this will allow you to help me a little better?

My guess is that _something_ on your system got broken at some point
between your first GR install and your first gr-fosphor attempt and
all your issues are stemming for this one unexpected condition.

i thought pybombs was self-contained, once i remove that shouldn't it be a complete restore? 

> OLD ISSUE - protobuf is still the old version and calling ./pybombs update
> protobuf does nothing

Should'nt matter, this recipe isn't required by gnuradio. Not even
sure why there is a recipe at all because it's not required by
anything. The message you get when you do a 'list' is more a warning
than anything else and not relevant here.

good to know about protobuf, thanks.

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]