[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Is it possible to undo my mistake

From: Carl Olsson
Subject: Re: [Discuss-gnuradio] Is it possible to undo my mistake
Date: Tue, 5 May 2015 21:16:28 +0200


Thank you very much for the help! Now it works, for some reason the solution to the first problem also solved the second or something else did.

Best regards,


On 3 May 2015 at 23:03, Richard Bell <address@hidden> wrote:
Add that source command to your .bashrc file which is located in your home directory. It is a hidden file. Every time you open a new terminal, the commands in .bashrc are automatically executed for you. After you add that line, make sure you close all old terminals and use new ones. 

The second problem is odd. You've made sure the file exists at the location? If it does, then I would ask if you are using WX Gui components? They are being phased out and have been discussed as having issues lately on the mailing list. I never use them. I would recommend replacing them all with QT components and trying that. Make sure you change the gui option in your options block too. 


Sent from my iPad

On May 3, 2015, at 10:59 AM, Carl Olsson <address@hidden> wrote:

Thank you very much for the answers.
I removed gnuradio by deleting my pybombs folder and deleting all files with gnuradio in the filename from my computer. Then I installed pybombs again and used it to install gnuradio. However now I have two problems that I didn't had before.

1) When I run the command: "gnuradio-companion" it doen't work if I don't first run "source ~/target/setup_env.sh".

2) When I run a flowgraph in grc with a scope sink I get the error message: "Can't load image from file '/usr/share/icons/hicolor/32x32/apps/gnuradio-grc.png': file does not exist."

Thank you so much for any help. I am new to Ubuntu so that's probably my problem..

Best regards


On 28 April 2015 at 08:55, Jan Krämer <address@hidden> wrote:
Hey Carl,

it seems that you just deleted the installed libraries, which can be easy to fix depending on how you installed GNURadio:

The most time consuming first:
If you have GNURadio installed via your package manager, then you will have to install it again using said paackage manager. Before that make sure that all GNURadio libraries are uninstalled first.

If you build GNURadio from source you might be lucky. If you still have your build directory and did not perform a make clean. All you have to do is go to that directory and do a
>sudo make install
>sudo ldconfig
takes a couple of seconds usually.

If you lost/deleted/burned your build directoty. you have to build GNURadio from scratch again. In both cases, make sure that previous versions of GNURadio are completely removed as well.

3: Install using Pybombs
I have not been able to use Pybombs at all so another one from the list might want to help you there :D But I suppose Pybombs keeps a build directory somewhere as well. So the pybombs equivalent of sudo make install should do the trick.
But as I said, for Pybombs don't rely on my expertise as I am just guessing here :D


2015-04-28 1:56 GMT+02:00 Richard Bell <address@hidden>:
Probably not without knowing exactly what was accidentally deleted.

What process do you use to install gnuradio that is so difficult to start over with? What OS?

On Ubuntu 14.04 using pybombs, it takes me about 35 minutes to completely wipe gnuradio from my machine to having it fully installed again. This should be possible for you too, assuming a standard setup.


On Mon, Apr 27, 2015 at 4:41 PM, Carl Olsson <address@hidden> wrote:
Dear all,

I followed a tutorial online to install a sdr software and accidentaly deleted files from my gnuradio installation. It took me a very long time to manage to set up everyting so before I start from the beginning I wanted to ask you if it is possible to undo my mistake. I am on Ubuntu 14.04 LTS and did:
cd user/local/lib
sudo rm libgnuradio*

Now when I run gnuradio-companion I get:

Cannot import gnuradio.

Is the python path environment variable set correctly?

Is the library path environment variable set correctly?
    Windows: PATH

Thank you all!

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]