[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] 2 USRP1s, both loads firmware correctly, but only

From: Marcus Müller
Subject: Re: [Discuss-gnuradio] 2 USRP1s, both loads firmware correctly, but only 1 can run ANY sdr apps. Why?
Date: Sat, 5 Dec 2015 10:19:38 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

Hi Peter,

wow: GNU Radio 3.4.2, that is OLD.

With firmwares that old, I can really not tell from experience how the USB behaviour should be -- the link (and bcdDevice numbers) you mention might or might not apply. The USRP firmwares have gone through significant rework since the libusrp times to now work consistently with UHD. Whilst libusrp used to be a GNU Radio component, UHD is a standalone driver that can be used by software such as OpenBTS without needing any GNU Radio to operate.

You don't need GNU Radio for modern OpenBTS, it integrates its own UHD driver interface as far as I know, which should be able to talk to your hardware; I might be incorrect, though - I've never used an USRP1 with OpenBTS.

I'm including the USRP-users mailing list in this reply -- this is really not much of a GNU Radio problem, and my hopes are that there are more people knowledgeable about firmware of that era over there. Please feel free to sign up to the list [1] and follow up there.

Best regards,

[1] http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

On 05.12.2015 01:45, Hi Hello wrote:

I have 2 USRP1s, and either issuing the commands of lsusrp, from Gnuradio-3.4.2, (to work with OpenBTS),  both USRP1s reports back that I have a USRP1 with WBX daughter cards.

And of the 2 USRPs, when I run lsusb -v, it DOES show the following correctly: bcdDevice 1.04  just as it should per this following link:  

Re: [Discuss-gnuradio] Can't find firmware: std.ihx
But if I run any SDR apps, such as OpenBTS, or USRP_benchmark.py, or USRPping,  one of the two USRP1s just sits there, while the other always works correctly.  When I ran USRP_benchmark.py on one of the USRP1s, while it doesn't report back anything, I'll disconnect the power cord, and then the command prompt reports back USB Protocol Errors -71.  The other USRP1, ( the one that works), when I pull the power cord, the command line reports back fusb repeatedly and it always works with NO issues.
Why would 2 USRP1s work correctly when loading firmware, but only 1 of them can run any SDR app without errors?  Both USRP1s are in mint condition too and have matching Molex USB connectors.
Please help.




Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]