[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] uhd_rx_cfile does not stop running

From: Alexander Levedahl
Subject: [Discuss-gnuradio] uhd_rx_cfile does not stop running
Date: Thu, 24 Mar 2016 10:44:53 -0400


I am using an X310.  Recently, I upgraded both gnuradio and uhd versions. 

For gnuradio, running gnuradio-config-info -v returns 33110293.

The most recent change number listed in the UHD changelog is 3.9.2

I recently upgraded the firmware version from 9 to 20 using:
uhd_image_loader --args="[type,address]" --fpga-path="[path]/usrp_x310_fpga_HGS.bit"

After burning the image I decided to run uhd_rx_cfile to make sure everything still worked:
uhd_rx_cfile --samp-rate=200e6 -f 2.45e9 -g 0 -N 200e6 -s ./test2.16iqle

This captures 200 million samples at a rate of 200MSps and stores them as complex short.

The file size was correct at 800MB, but the process would not terminate.  Prior to doing these upgrades, the process would terminate when it reached the end of the file.

When I ran the process, the first line printed is:
linux; GNU C++ version 4.4.7 20120313 (Red Hat 4.4.7-4); Boost_105600; UHD_003.010.git-0-unknown.

I am fairly certain the version of UHD I used is 3.9.2, not 3.10.  I saw an email recently that 3.9.3 was just released, so I am mildly confused as to why 3.10 is being printed. 

In addition, when I ran uhd_rx_cfile with th -v option it failed on print the Receiving on {} channels line, because of "ValueError: zero length field name in format".  Commenting that line out fixed the issue.  None of the rest of the information looked incorrect.

Finally, the ettus man page on usrp_x3x0, says to burn the XGS image when using 10 Gigabit and HGS when using 1 Gigabit.  However, I can only find an HG and an HGS image. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]