[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Pybomb installation error

From: Shahnaz Shirazi
Subject: Re: [Discuss-gnuradio] Pybomb installation error
Date: Mon, 2 May 2016 20:50:34 -0700

Just an update.

I found the Pybomb source cod got updated to try it one more time
All step went through without error except the installation.
I got bellow error after running last command to install the Gnu radio:

PyBombs.Packager.pip - ERROR - Command '['pip', 'list']' returned non-zero exit status 2PyBombs.Packager.pip - ERROR - Could not run pip list. Hm.PyBombs.Packager.pip - DEBUG - Loading pip install cache.

my Pymobmbs version is 2.0.1
pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2.7)

Ununtu 14.04.4-desktop-

look forward for an update.
If anyone got it to work recently I would appreciate your feedback.

On Sat, Apr 23, 2016 at 4:50 PM, Shahnaz Shirazi <address@hidden> wrote:
Hi Nathan,

After trying the new Pybomb cod I'm not able to initialize the prefix.
I think some dependency is broken in new pybomb source file.
I get below error after installing pybombs

    Installing pybombs script to /usr/local/bin
  Could not find .egg-info directory in install record for PyBOMBS==2.0.1 from git+https://github.com/gnuradio/pybombs.git in /usr/local/lib/python2.7/dist-packages
Successfully installed setuptools requests PyBOMBS
Cleaning up...

after trying to use any pybomb command I'm getting an error.
here is after trying to make a prefix:

address@hidden:~$ pybombs prefix init /home/shahnaz/lab -a mylab
Traceback (most recent call last):
  File "/usr/local/bin/pybombs", line 9, in <module>
    load_entry_point('PyBOMBS==2.0.1', 'console_scripts', 'pybombs')()
  File "/usr/local/lib/python2.7/dist-packages/pybombs/main.py", line 30, in main
    return dispatch() or 0
  File "/usr/local/lib/python2.7/dist-packages/pybombs/commands/base.py", line 141, in dispatch
    return get_cmd_dict(cmd_list)[args.command](cmd=args.command, args=args).run()
  File "/usr/local/lib/python2.7/dist-packages/pybombs/commands/prefix.py", line 102, in run
    return self.prefix_cmd_name_list[self.args.prefix_command]['run'](self)
  File "/usr/local/lib/python2.7/dist-packages/pybombs/commands/prefix.py", line 150, in _run_init
    if op.exists(op.join(path, self.prefix.prefix_conf_dir)):
AttributeError: 'NoneType' object has no attribute 'prefix_conf_dir'

I've deleted and reinstalled my virtual machine multiple times to make sure it's new and nothing broken before running the cod.


On Thu, Apr 21, 2016 at 8:53 AM, West, Nathan <address@hidden> wrote:

On Thu, Apr 21, 2016 at 11:23 AM, Jason Matusiak <address@hidden> wrote:
> $ pybombs [-p myprefix] install gnuradio gr-osmosdr -v

I ran it, but it thinks that -v is a recipe and it errors out there.  If instead I run $ pybombs -v [-p myprefix] -v install gnuradio gr-osmosdr, i get:
PyBombs.Packager.source - DEBUG - Configuring recipe uhd
PyBombs.Packager.source - DEBUG - Using vars - {'config_opt': '', 'builddir': '/home/jmat/gnuradio/src/uhd/build'}
PyBombs.Packager.source - DEBUG - In cwd - /home/jmat/gnuradio/src/uhd/build
PyBombs._process_thread() - DEBUG - Executing command `CC= CXX= cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/home/jmat/gnuradio  -Wno-dev'
CMake Error: The source directory "/home/jmat/gnuradio/src/uhd" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
PyBombs.monitor_process() - DEBUG - Thread signaled termination or returned
PyBombs.monitor_process() - DEBUG - Return value: 1
PyBombs.Packager.source - ERROR - Problem occurred while building package uhd:
Process returned value: 1
PyBombs.install - ERROR - Error installing package uhd. Aborting.

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]